Bug 250098 - Wrong month short names for fr_FR
Wrong month short names for fr_FR
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: glibc (Show other bugs)
4.0
All Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-30 10:30 EDT by Thomas Schwanhäuser
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-03 05:36:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Schwanhäuser 2007-07-30 10:30:20 EDT
Description of problem:

One can not distinguish June and July, because their shortnames are abbreviated 
too much.


Version-Release number of selected component (if applicable):


How reproducible:

echo short month name of day 18-July-2006 and 18-June-2006

  
Actual results:

18-June-2006 gets 18-Jui-2006
18-July-2006 gets 18-Jui-2006


Expected results:

Windows does it in the following way, seems reasonable:

18-juin-07

and 

18-juil.-07
Comment 1 Jakub Jelinek 2007-07-30 10:42:30 EDT
Which glibc version or RHEL version?
I have tried all of RHEL3, RHEL4 and RHEL5 glibc and all of them use
jun as abbrev. for June and jui for July.
Comment 2 Thomas Schwanhäuser 2007-07-30 10:59:17 EDT
Arch   : x86_64
Version: 2.5
Release: 18.fc6


Additional info: We're using %b in strftime.


Best regards,


Thomas


Comment 3 Jakub Jelinek 2007-07-30 11:11:58 EDT
Then it surely has nothing to do with RHEL, so why are you filling it against
RHEL?
That said, in FC6 I get:
LC_ALL=fr_FR.UTF-8 locale LC_TIME -k | grep abmon
abmon="jan;fev;mar;avr;mai;jun;jui;aou;sep;oct;nov;dec"
(and similarly for fr_FR), so unless you use your custom locale for fr_FR, you
really can't see the same abmon names for June and July.  Also note that glibc
abmon names are lowercase.

LC_ALL=fr_FR.UTF-8 date -d 2007-06-01
ven jun  1 00:00:00 CEST 2007
LC_ALL=fr_FR.UTF-8 date -d 2007-07-01
dim jui  1 00:00:00 CEST 2007
LC_ALL=fr_FR date -d 2007-06-01 | iconv -f ISO-8859-15// -t UTF-8//
ven jun  1 00:00:00 CEST 2007
LC_ALL=fr_FR date -d 2007-07-01 | iconv -f ISO-8859-15// -t UTF-8//
dim jui  1 00:00:00 CEST 2007
Comment 4 Jakub Jelinek 2007-08-03 05:36:26 EDT
Can't reproduce anywhere, closing.

Note You need to log in before you can comment on or make changes to this bug.