Bug 2501 - inserting modules (ppa, imm) gives unresolved symbol error
inserting modules (ppa, imm) gives unresolved symbol error
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-05-03 08:58 EDT by Q Enterix
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 14:26:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Q Enterix 1999-05-03 08:58:51 EDT
# insmod ppa
/lib/modules/2.2.5-15/scsi/ppa.o: unresolved symbol
parport_claim_Rcca15f23
/lib/modules/2.2.5-15/scsi/ppa.o: unresolved symbol
parport_register_device_R064ebecf
/lib/modules/2.2.5-15/scsi/ppa.o: unresolved symbol
parport_unregister_device_R3618c96f
/lib/modules/2.2.5-15/scsi/ppa.o: unresolved symbol
parport_enumerate_R648d1e26
/lib/modules/2.2.5-15/scsi/ppa.o: unresolved symbol
parport_release_R4430d136
Comment 1 Bill Nottingham 1999-05-03 11:01:59 EDT
Use modprobe instead, or insert the required modules first.
Comment 2 Q Enterix 1999-05-04 08:57:59 EDT
It looks like more than "user error" to me...
There is a coiple of people complaining on newsgroups.

System:

RH 6.0, kernel 2.2.5-15 & 2.2.5-20

The problem:

Kernel module ppa (Parallel ZIP drive) gives errors during boot
(before /etc/conf.modules is check!) and after boot while inserting
manually. The 2.2 kernel handles ppa diffrent than 2.0. You can
install ZIP manually by

# insmod parport; insmod parport_pc; insmod ppa

but jaZip application coredumps and leaves system in notstable state.
This is an ugly work around for people that depend on parallel ZIP and
upgraded from 5.2 to 6.0.
Comment 3 Q Enterix 1999-05-05 12:33:59 EDT
found the problem:

modprobe gives also errors (modprobe ppa)
file /lib/modules/2.2.5-15/modules.dep needs to be edited

line:
/lib/modules/2.2.5-15/scsi/ppa.o: /lib/modules/2.2.5-15/misc/parport.o
/lib/modules/2.2.5-15/misc/parport_pc.o

without "parport_pc.o" modprobe ppa gives errors


------- Additional Comments From   06/08/99 09:39 -------
I got module insertion working fine using appropriate entries in
rc.modules on bootup and the appropriate entries in conf.modules.  Go
the the parport driver website and read up on the new parport
driver.  I used info gleaned from there to make things work for me.
Email and I'll let you know exactly how I set mine up.
Comment 4 Jeff Johnson 1999-06-14 14:04:59 EDT
*** Bug 3430 has been marked as a duplicate of this bug. ***

When booting with the Red Hat floppy, the parallel zip
drive (via scsi4) is not detected, probably because
support is not in the kernel. (I happen to know that
you have to use scsi to access the parallel port zip).

When I select, during installation at item "SCSI
Configuration", "Do you have a SCSI adapter? Yes" and
"Iomega PPA3 (parallel port zip" + "Autoprobe", I get
the error: "I can't find the device anywhere on your
system!". Virtual console 3 (Alt-F3) reveals:
"* running /bin/insmod /bin/insmod /modules/ppa.o"
"* insmod failed!"
Note the double /bin/insmod, which imho is an erroneous
call. However, when I try in Alt-F2 console:
/bin/insmod /modules/ppa.o
I get the error: "Cannot find archive member ppa.o:
file does not exist in archive".
Note that /modules is properly symlinked to the right
directory on the, also properly mounted, cdrom.
Comment 5 Michael K. Johnson 1999-07-13 15:55:59 EDT
As far as I can tell, the only problem here is in the install,
since correctly using modprobe instead of insmod fixes the problem
outside of the install.  I am therefore changing the component to
"installer".
Comment 6 Jay Turner 2000-02-10 14:26:59 EST
Issue is resolved in the latest installer, as the ppa module in not included in
the installer modules, as the Zip drive cannot be used for installation.

Note You need to log in before you can comment on or make changes to this bug.