Bug 250141 - memcached fails to start
memcached fails to start
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: memcached (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Paul Lindner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-30 13:22 EDT by Edward Rudd
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version: 1.2.3-7.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-10 18:23:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace from running memcached -p 11211 -u nobody -m 64 -c 1024 -d -P /var/run/memcached/memcached.pid (5.21 KB, text/plain)
2007-07-31 19:28 EDT, Edward Rudd
no flags Details

  None (edit)
Description Edward Rudd 2007-07-30 13:22:12 EDT
Description of problem:
Memcached fails to start.

Version-Release number of selected component (if applicable):
1.2.3-4.fc7

How reproducible:


Steps to Reproduce:
1. service memcached start
  
Actual results:
memcached is not in the process list and not running

Expected results:
it to be running

Additional info:
pid file is written, but process dies after writing pid.

If I run manually and do not specify -d, it starts fine and writes the pid (but
it will not be forked to the background).
memcached -p 1211 -u nobody -m 64 -c 1024 -P /var/run/memcached/memcached.pid

if I don't specify -P it starts fine as well
memcached -p 1211 -u nobody -m 64 -c 1024 -d

but if both -d and -P are specified memcached fails to start.
Comment 1 Paul Lindner 2007-07-30 13:58:34 EDT
I can't reproduce this..

Can you include your /etc/sysconfig/memcached file along with the output of:

  sh -x /etc/init.d/memcached start


Thanks!

Also, is selinux on or off?

I don't believe that I've tested memcached with selinux.



Comment 2 Edward Rudd 2007-07-31 19:22:59 EDT
selinux is disabled.
sh -x doesn't show anything relevant. as the init script believes it started.

running it manually (bypassing the init script entirely) with both -d and -P
caused it to fail starting so it is not the init script, it is memcached itself.

My home F7 system works fine, but it is running i386, not x86_64 F7.

-- relevant sh -x output
+ echo -n 'Starting memcached: '
Starting memcached: + chown nobody /var/run/memcached
+ daemon --pidfile /var/run/memcached/memcached.pid memcached -d -p 11211 -u
nobody -m 64 -c 1024 -P /var/run/memcached/memcached.pid
+ local gotbase= force= nicelevel corelimit
+ local pid base= user= nice= bg= pid_file=
+ nicelevel=0
+ '[' --pidfile '!=' -pidfile ']'
+ case $1 in
+ pid_file=/var/run/memcached/memcached.pid
+ shift 2
+ '[' memcached '!=' memcached ']'
+ '[' -z '' ']'
+ base=memcached
+ __pids_var_run memcached /var/run/memcached/memcached.pid
+ local base=memcached
+ local pid_file=/var/run/memcached/memcached.pid
+ pid=
+ '[' -f /var/run/memcached/memcached.pid ']'
+ return 3
+ '[' -n '' -a -z '' ']'
+ corelimit='ulimit -S -c 0'
+ '[' -n '' ']'
+ '[' color = verbose -a -z '' ']'
+ '[' -z '' ']'
+ /bin/bash -c 'ulimit -S -c 0 >/dev/null 2>&1 ; memcached -d -p 11211 -u nobody
 -m 64 -c 1024 -P /var/run/memcached/memcached.pid'
+ '[' 0 -eq 0 ']'
+ success 'memcached startup'
+ '[' color '!=' verbose -a -z '' ']'
+ echo_success
+ '[' color = color ']'
+ echo -en '\033[60G'
                                                           + echo -n '['
[+ '[' color = color ']'
+ echo -en '\033[0;32m'
+ echo -n '  OK  '
  OK  + '[' color = color ']'
+ echo -en '\033[0;39m'
+ echo -n ']'
]+ echo -ne '\r'
+ return 0
+ return 0
+ RETVAL=0
+ echo

+ '[' 0 -eq 0 ']'
+ touch /var/lock/subsys/memcached
+ exit 0
Comment 3 Edward Rudd 2007-07-31 19:28:09 EDT
Created attachment 160381 [details]
Strace from running  memcached  -p 11211 -u nobody -m 64 -c 1024  -d -P /var/run/memcached/memcached.pid

I am noticing entries in my audit log after I attempt to start memcached
type=ANOM_ABEND msg=audit(1185923738.925:9230): auid=13183 uid=99 gid=99
pid=16518 comm="memcached" sig=11
type=ANOM_ABEND msg=audit(1185923766.989:9231): auid=13183 uid=99 gid=99
pid=16565 comm="memcached" sig=11
type=ANOM_ABEND msg=audit(1185923975.923:9232): auid=13183 uid=99 gid=99
pid=16604 comm="memcached" sig=11
type=ANOM_ABEND msg=audit(1185923988.074:9233): auid=13183 uid=99 gid=99
pid=16723 comm="memcached" sig=11
Comment 4 Paul Lindner 2007-08-06 11:57:03 EDT
Found this.  It's a bad interaction with libevent on x86_64. Fixed in 1.2.3-7
release.

Comment 5 Fedora Update System 2007-08-08 11:26:13 EDT
memcached-1.2.3-7.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2007-08-10 18:23:02 EDT
memcached-1.2.3-7.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.