Bug 250182 - Traceback when starting on ppc(64)
Summary: Traceback when starting on ppc(64)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: audit   
(Show other bugs)
Version: rawhide
Hardware: powerpc
OS: Linux
low
low
Target Milestone: ---
Assignee: Steve Grubb
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F8Blocker
TreeView+ depends on / blocked
 
Reported: 2007-07-30 21:47 UTC by Jesse Keating
Modified: 2013-01-10 02:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-01 18:55:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jesse Keating 2007-07-30 21:47:03 UTC
Not 100% sure that it's PPC only, but I haven't seen it on any other arch.

Traceback (most recent call last):
  File "/usr/sbin/setroubleshootd", line 81, in <module>
    from setroubleshoot.server import RunFaultServer
  File "/usr/lib/python2.5/site-packages/setroubleshoot/server.py", line 25, in
<module>
    from setroubleshoot.analyze import *
  File "/usr/lib/python2.5/site-packages/setroubleshoot/analyze.py", line 29, in
<module>
    from setroubleshoot.avc_audit import *
  File "/usr/lib/python2.5/site-packages/setroubleshoot/avc_audit.py", line 24,
in <module>
    import audit
  File "/usr/lib/python2.5/site-packages/audit.py", line 51, in <module>
    class __vector128(_object):
  File "/usr/lib/python2.5/site-packages/audit.py", line 57, in __vector128
    __swig_setmethods__["u"] = _audit.__vector128_u_set
AttributeError: 'module' object has no attribute '_vector128__vector128_u_set'

Comment 1 Jeremy Katz 2007-10-01 18:05:45 UTC
Is this still happening? 

Comment 2 John Dennis 2007-10-01 18:40:29 UTC
This apparently a dup of bug 251327, which happens to be a RHEL bug, to the best
of my knowledge this is fixed. The problem was in the swig bindings for
auditlibs. I believe the problem was fixed by Steve Grubb who modified the swig
input to avoid problems with swig name mangling.

Changing component to audit and owner to sgrubb

Comment 3 Steve Grubb 2007-10-01 18:55:43 UTC
Yes this is a dupe of that bug and was fixed in audit-1.5.6. Rawhide is now
running audit-1.6.2, so the fix should be included. Closing this one.


Note You need to log in before you can comment on or make changes to this bug.