Bug 250190 - RHEL5.1 - Kernel Panic after installation to a cciss drive
RHEL5.1 - Kernel Panic after installation to a cciss drive
Status: CLOSED DUPLICATE of bug 249104
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
ia64 Linux
low Severity medium
: ---
: ---
Assigned To: Doug Chapman
Martin Jenner
Depends On:
  Show dependency treegraph
Reported: 2007-07-30 18:28 EDT by Marilise Cover
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-17 13:49:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Marilise Cover 2007-07-30 18:28:02 EDT
Description of problem: System does not boot, and it gives the following message:
Kernel panic - not syncing: Attempted to kill init!
Hardware Configuration:RX3600

Date/Time:  Jul 30, 2007  21:58:57  (20:07:07:30:21:58:57)
Manufacturer:  hp
Product Name:  server rx3600
Product Number:  AB596A
Serial Number:  USE0609KLC
UUID:  8CF4AA42-C3E3-11DA-9048-E246ADD8402C
System Bus Frequency:  333 MHz                                                  
Current firmware revisions
MP FW     : F.02.09
 BMC FW    : 70.59
 EFI FW    : ROM A 05.66, ROM B 06.15
 System FW : ROM A 02.03, ROM B 82.01, Boot ROM B
 PDH FW    : 50.07
 DHPC FW   : 01.23
 UCIO FW   : 03.0b
 PRS FW    : 00.08 UpSeqRev: 0c, DownSeqRev: 08
 HFC FW    : 00.04 SetRev: 00

           # of               L3      L4      Family/
   CPU     Logical            Cache   Cache   Model         Processor
   Module  CPUs     Speed     Size    Size    (hex.)   Rev  State
   ------  -------  --------  ------  ------  -------  ---  ------------
     0        4     1.66 GHz    9 MB    None   20/01    A1        Active
     1        4     1.66 GHz    9 MB    None   20/01    A1        Active

CPU threads are turned on.
CPU pstates are turned on

Extender 0:
     ---- DIMM A -----  ---- DIMM B -----
      DIMM   Current     DIMM   Current
---  ------ ----------  ------ ----------
 0    512MB     Active   512MB     Active
 1    512MB     Active   512MB     Active

Extender 1:
     ---- DIMM A -----  ---- DIMM B -----
      DIMM   Current     DIMM   Current
---  ------ ----------  ------ ----------
 0    ----               ----
 1    ----               ----

   Active Memory    : 2048 MB
   Installed Memory : 2048 MB
- Intent of the test and software setup:
- cpuconfig threads on
- use a default installation onto one of the internal storage drives
  (SAS RAID 1+0), HP Smart Array P600
- include at least one of each HBA (and devices on all ports):
  Redstone (core I/O), plug-in Redstone, A7173A, AD167A, AD168A, 
  AB429A, (RAID cards must have at least one each RAID 0, RAID 1+0, and RAID 5
  or ADG volume connected)
- use an additional Redstone as core I/O (AB352A moves to slot 10)
- a Qlogic card was placed in a shared slot 9 for this test, 

After the hardware was setup and the OS installed the system did not boot,
Examples of messages:
cciss: out of memory
cciss: out of memory
cciss: out of memory
cciss: out of memory
    setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
          append="dom_mem=1G -- rhgb"                                          
Version-Release number of selected component (if applicable):
RHEL 5.1 Partner Beta, vmm=xen.gz-2.6.18-36.el5

How reproducible: always

Steps to Reproduce:
- follow test intent,
Actual results:
- Kernel panic - not syncing: Attempted to kill init!

Expected results:
- System boots to OS

Additional info: will reinstall the OS to different storage
Comment 1 Doug Chapman 2007-07-31 16:00:52 EDT
It appears that this is probably a dup of 249104 which will be fixed in the next
kernel.  The fix for that issue was not in in time for the beta.
Comment 2 Stephen Tweedie 2007-07-31 16:09:25 EDT
Looks like a core kernel problem, not xen-specific; reassigning for now.
Comment 3 Doug Chapman 2007-07-31 17:57:16 EDT

I think what you are seeing is directly related to the "cciss: out of memory"
errors which is fixed.  Can you grab the latest kernel from:


and verify the problem goes away?


- Doug
Comment 4 Ernie Petrides 2007-09-05 15:28:04 EDT
Hello, Marilise.  Could you please retest on the kernel described
above in comment #3?  We think this is a dup of bug 249104, which
has been fixed in that kernel.

Thanks in advance.
Comment 5 Doug Chapman 2007-09-13 17:39:33 EDT

I believe this issue is resolved.  Let me know ASAP if you think otherwise.


- Doug
Comment 6 Doug Chapman 2007-09-17 13:49:33 EDT
This has been verifed as being fixed.  It is the same issue as 249104.

*** This bug has been marked as a duplicate of 249104 ***

Note You need to log in before you can comment on or make changes to this bug.