Bug 250208 - grpck truncates long lines
grpck truncates long lines
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: shadow-utils (Show other bugs)
4.0
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Vrabec
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-30 21:42 EDT by John Newbigin
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-31 06:05:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Newbigin 2007-07-30 21:42:12 EDT
Description of problem:
grpck does not handle large groups


Version-Release number of selected component (if applicable):
shadow-utils-4.0.3-61.RHEL4


How reproducible:
Every time


Steps to Reproduce: (untested procedure)
1. create a new group
2. add lots of users until the line in /etc/group is longer than ~30000 characters
3. run grpck
4. grpck has truncated the line and so possibly truncated a user name.  The
truncated user does not exist and grpck wants to remove the user
  
Actual results:


Expected results:
Other tools support groups this large so grpch should also.

Additional info:
Comment 1 John Newbigin 2007-07-31 05:19:50 EDT
I did some further digging and found the problem. It was actually our gshadow
file. It does have corruption but it was caused by 2.1AS and not EL4. grpck was
actually doing the correct thing. Sorry about the false report.

Note You need to log in before you can comment on or make changes to this bug.