Bug 250209 - Yum proxy settings ignored when EPEL repo is installed
Summary: Yum proxy settings ignored when EPEL repo is installed
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-31 01:51 UTC by tony
Modified: 2009-03-25 06:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 06:18:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description tony 2007-07-31 01:51:43 UTC
Description of problem: When the EPEL repo is installed, the proxy settings
residing in /etc/sysconfig/rhn/up2date are ignored. At my worksite, these proxy
name and password are required to access the wider world. After installation of
the EPEL, yum could not get through the proxy / firewall.


Version-Release number of selected component (if applicable):


How reproducible: Always


Steps to Reproduce:
1. type "yum update"
2. process hangs at 
3. "Setting up repositories"
4. Quitting by "ctrl c" brings up the following error message:

Could not retrieve mirrorlist
http://mirrors.fedoraproject.org/mirrorlist?repo=epel-5&arch=i386 error was
[Errno 4] IOError: <urlopen error (4, 'Interrupted system call')>
Error: Cannot find a valid baseurl for repo: epel
  
Actual results: See above


Expected results: The upgrade process to go ahead as normal


Additional info: I can get yum to work by entering the proxy:password details
before running the yum command.

Comment 1 Kevin Fenzi 2007-08-07 03:09:44 UTC
As far as I know yum doesn't have any way of reading the proxy settings that are
set in up2date. :( 

Does yum work natively to download your RHEL channels with the correct proxy
without having the epel repository enabled? 

This seems like an issue with the RHEL yum not being able to read those proxy
settings from up2date.

Comment 2 James Antill 2009-03-25 06:18:46 UTC
yum reads it's proxy info. from /etc/yum.conf ... however when using yum with yum-rhn-plugin, the RHN part takes over file downloads (due to the complexity of RHN interaction) and that uses the proxy info. in the up2date dir.


Note You need to log in before you can comment on or make changes to this bug.