This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 250221 - eclipse does not start up
eclipse does not start up
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-07-30 23:15 EDT by Jens Petersen
Modified: 2008-07-17 17:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-04 11:56:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
workspace/.metadata/.log (15.11 KB, text/plain)
2007-07-31 00:00 EDT, Jens Petersen
no flags Details
workspace/.metadata/.log (21.33 KB, text/plain)
2007-08-02 02:14 EDT, Jens Petersen
no flags Details

  None (edit)
Description Jens Petersen 2007-07-30 23:15:11 EDT
Description of problem:
In current Fedora development I cannot get eclipse to start.

Version-Release number of selected component (if applicable):
eclipse-3.3.0-3.fc8.i386

How reproducible:
every time

Steps to Reproduce:
1. run eclipse
  
Actual results:
Flash window appears followed by an error dialog:

"An error has occurred. See the log file..."

Expected results:
No error
Comment 1 Jens Petersen 2007-07-31 00:00:57 EDT
Created attachment 160292 [details]
workspace/.metadata/.log
Comment 2 Ben Konrath 2007-07-31 16:41:48 EDT
Can you try changing 'eclipse.product=org.eclipse.sdk.ide' to
'eclipse.product=org.eclipse.platform.ide' in
/usr/lib/eclipse/configuration/config.ini and let me know if that fixes the
problem? Thanks.
Comment 3 Ben Konrath 2007-07-31 17:14:31 EDT
Scratch that. I think the problem is with the Manifest files I put in the Lucene
jars. I'll update the lucene packages tomorrow and get you to test things then.
Thanks, Ben
Comment 4 Ben Konrath 2007-07-31 17:35:24 EDT
Ok, I just pushed the lucene build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=84077

Can you test eclipse with that version of lucene? THanks, Ben
Comment 5 Jens Petersen 2007-08-01 04:18:24 EDT
It still gave an error.  I can try again later with the new eclipse build.
Comment 6 Jens Petersen 2007-08-02 00:59:14 EDT
I tried eclipse-3.3.0-4.fc8 now and still get an error dialog at startup.

It would be nice to have working eclipse in test1 but maybe too late now?
Comment 7 Jens Petersen 2007-08-02 02:14:44 EDT
Created attachment 160498 [details]
workspace/.metadata/.log
Comment 8 Ben Konrath 2007-08-02 14:28:14 EDT
I can't reproduce this problem. Can you try running with a clean workspace and
~/.eclipse directory. Just run:

mv ~/.eclipse ~/.eclipse-back

and then run eclipse with:

eclipse -data workspace-test

Let me know how that goes. Ben
Comment 9 Ben Konrath 2007-08-02 15:49:13 EDT
In addition, could you try this line:

for f in `rpm -aq | egrep "eclipse|swt"`; do rpm -qV $f; done

and post the output? Thanks, Ben
Comment 10 Jens Petersen 2007-08-02 19:08:19 EDT
(In reply to comment #8)
> Can you try running with a clean workspace and
> ~/.eclipse directory. Just run:
> mv ~/.eclipse ~/.eclipse-back
> and then run eclipse with:
> eclipse -data workspace-test

That gives me an error dialog again.

(In reply to comment #9)
> In addition, could you try this line:
> for f in `rpm -aq | egrep "eclipse|swt"`; do rpm -qV $f; done

No output.

I will certainly try again when the latest eclipse packages land
in fedora devel after test1.
Comment 11 Jens Petersen 2007-08-16 03:52:50 EDT
I guess this is related to selinux.

If I set "setenforcing permissive", eclipse runs fine for me.
Comment 12 Andrew Overholt 2007-08-16 09:44:05 EDT
Do you have any SELinux failures specifically mentioned in the panel applet
thingy or in a log somewhere?
Comment 13 Jens Petersen 2007-08-16 18:58:38 EDT
Nope, I don't see any.
Comment 14 Jens Petersen 2007-08-23 20:17:10 EDT
Adding dwalsh to cc.
Comment 15 Daniel Walsh 2007-08-24 09:41:43 EDT
Are you seeing avc messages in /var/log/audid/audit.log or /var/log/messages
This is probably a badly written/labeled shared library.
Comment 16 Jens Petersen 2007-08-26 21:25:01 EDT
Yes, in /var/log/audid/audit.log:

type=AVC msg=audit(1187913845.427:80): avc:  denied  { execmem } for  pid=6126
comm="eclipse" scontext=system_u:system_r:unconfined_t:s0
tcontext=system_u:system_r:unconfined_t:s0 tclass=process
type=SYSCALL msg=audit(1187913845.427:80): arch=40000003 syscall=192 success=no
exit=-13 a0=0 a1=2000 a2=7 a3=22 items=0 ppid=1 pid=6126 auid=500 uid=500
gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none)
comm="eclipse" exe="/usr/lib/eclipse/eclipse"
subj=system_u:system_r:unconfined_t:s0 key=(null)
type=AVC msg=audit(1188177305.231:72): avc:  denied  { execmem } for  pid=3185
comm="eclipse" scontext=system_u:system_r:unconfined_t:s0
tcontext=system_u:system_r:unconfined_t:s0 tclass=process
type=SYSCALL msg=audit(1188177305.231:72): arch=40000003 syscall=192 success=no
exit=-13 a0=0 a1=2000 a2=7 a3=22 items=0 ppid=1 pid=3185 auid=500 uid=500
gid=500 euid=500 suid=500 fsuid=500 egid=500 sgid=500 fsgid=500 tty=(none)
comm="eclipse" exe="/usr/lib/eclipse/eclipse"
subj=system_u:system_r:unconfined_t:s0 key=(null)
Comment 17 Daniel Walsh 2007-08-27 09:33:47 EDT
Has eclipse always needed execmem?  Is this caused by java?
Comment 18 Daniel Walsh 2007-08-27 09:48:59 EDT
If you execute the following eclipse should work

semanage fcontext -a -t java_exec_t /usr/lib/eclipse/eclipse
restorecon -v /usr/lib/eclipse/eclipse
Comment 19 Ben Konrath 2007-08-28 13:25:08 EDT
(In reply to comment #17)
> Has eclipse always needed execmem?  Is this caused by java?

There were changes made to the launcher in Eclipse 3.3.0 so that's probably
causing the problem.

(In reply to comment #18)
> If you execute the following eclipse should work
> 
> semanage fcontext -a -t java_exec_t /usr/lib/eclipse/eclipse
> restorecon -v /usr/lib/eclipse/eclipse

Is there something that I should do to get this changed on the system. I have to
admit to knowing very little about selinux but I'm willing to learn. If you have
a URL that I should checkout, just let me know. Thanks, Ben
Comment 20 Daniel Walsh 2007-08-28 14:50:49 EDT
Not sure what you are asking Ben?  As far as intro to SELinux

danwalsh.livejournal.com is my blog for "SELinux for dummies", 

If you want to know about execmem/execmod.

http://people.redhat.com/~drepper/selinux-mem.html
Comment 21 Ben Konrath 2007-08-28 15:49:48 EDT
Thanks for the links. I just want to know if I need to do anything to make
eclipse work when selinux is turned on. Or will users always need to run these
commands?:

semanage fcontext -a -t java_exec_t /usr/lib/eclipse/eclipse
restorecon -v /usr/lib/eclipse/eclipse
Comment 22 Jens Petersen 2007-08-28 20:02:53 EDT
Can that be done in eclipse.spec or should it be added to selinux-policy?
Comment 23 Daniel Walsh 2007-08-29 06:17:11 EDT
No I have added labeling of eclipse as a java_exec_t in the latest rawhide
policy.  So if execmem is really necessary, I will leave the label.
Comment 24 Jeremy Katz 2007-10-04 11:56:51 EDT
Eclipse seems to work in the test3 live CD with selinux enabled.
Comment 25 Andrew Overholt 2008-07-17 17:15:22 EDT
I don't know who changed this to rawhide but right now it's expected that it
won't start on a fresh rawhide installation.  I'm trying to get Eclipse 3.4 in
and should hopefully have a build on at least x86, x86_64, and ppc by tomorrow.

Note You need to log in before you can comment on or make changes to this bug.