Bug 250245 - SELinux CUPS Bug for Brother MFC420CN Networked FAX/Scanner/Printer
SELinux CUPS Bug for Brother MFC420CN Networked FAX/Scanner/Printer
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-31 08:09 EDT by Larry Perritt-Hayes
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 13:08:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Selinux Troubleshooting Browser (2.32 KB, text/plain)
2007-07-31 08:09 EDT, Larry Perritt-Hayes
no flags Details

  None (edit)
Description Larry Perritt-Hayes 2007-07-31 08:09:21 EDT
Description of problem:
Trying to print anything to my MFC420CN on the LAN.


Version-Release number of selected component (if applicable):
Current CUPS driver for MFC420CN.


How reproducible:
When the printer is activated.


Steps to Reproduce:
1. Open printer manager.
2. Enable printer.
3. Printing a test page or any other document.
  
Actual results:
A setroubleshoot browser pops--giving the information attached.

Expected results:
A test page or any other document to print normally.


Additional info:
I need a fix--this works fine for XP--it's on our wireless LAN.  The printer,
obviously, is plugged into the Ethernet router.
Comment 1 Larry Perritt-Hayes 2007-07-31 08:09:21 EDT
Created attachment 160307 [details]
Selinux Troubleshooting Browser
Comment 2 Larry Perritt-Hayes 2007-07-31 08:11:03 EDT
Thank you for your work on this problem.
Comment 3 Daniel Walsh 2007-07-31 11:00:33 EDT
You can 

chcon -t bin_t FULLPATH/brlpdwrapperMFC

This will make it executable by cupsd.  You can also make this change permanent
by executing

semanage fcontext -a -t bin_t FULLPATH/brlpdwrapperMFC

Also please give me the FULLPATH/brldwrapperMFS so I can make the policy correct
so other users don't stumble on this problem.
Comment 4 Larry Perritt-Hayes 2007-07-31 13:26:51 EDT
Still not printing.

Same message.

FULLPATH= /usr/lib/cups/filter/brlpdwrapperMFC420CN, per your request.

"SEMANAGE" is not a valid command, it seems.

Please reply.

Thank you.
Comment 5 Daniel Walsh 2007-07-31 13:43:51 EDT
restorecon -v /usr/lib/cups/filter/brlpdwrapperMFC420CN
should fix the context.
Comment 6 Daniel Walsh 2007-07-31 13:44:36 EDT
selinux-policy-2.6.4-30 will fix the labeling of this directory to default to bin_t
Comment 7 Larry Perritt-Hayes 2007-07-31 14:39:27 EDT
"restorecon" is not a valid command.

...and..how do I quickly set the suggested selinux policy?
Comment 8 Daniel Walsh 2007-07-31 15:48:04 EDT
/sbin/restorecon -v /usr/lib/cups/filter/brlpdwrapperMFC420CN

You don't need it if you run this command.  

30 will go into fedora-testing tonight.
Comment 9 Larry Perritt-Hayes 2007-07-31 16:11:48 EDT
Ok, the command executed, however, I still get the same message without printer
throughput.

Keep me posted with PTF.

Thank you.
Comment 10 Daniel Walsh 2007-08-01 10:58:55 EDT
Could you attach you /var/log/audit/audit.log?
Comment 11 Larry Perritt-Hayes 2007-08-01 11:20:48 EDT
Sure, I would, but it's empty.

Thanks for the progress.  Let me know.
Comment 12 Daniel Walsh 2007-08-01 11:38:46 EDT
Ok in that case, if you setenforce 0 does it work?  If not, then it is probably
not an SELinux problem.
Comment 13 Larry Perritt-Hayes 2007-08-01 13:26:09 EDT
Ok, I'll keep worrking on it and keep you updated when it works.

Thanks for your time.
Comment 14 Daniel Walsh 2007-09-12 13:08:20 EDT
Moving modified bugs to closed

Note You need to log in before you can comment on or make changes to this bug.