Bug 250248 - msghack crashes due to Unicode in header
Summary: msghack crashes due to Unicode in header
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gettext   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-31 12:40 UTC by Dwayne Bailey
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-01 07:31:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for encoding (261 bytes, patch)
2007-07-31 12:40 UTC, Dwayne Bailey
no flags Details | Diff

Description Dwayne Bailey 2007-07-31 12:40:29 UTC
Description of problem:
msghack crashes

Version-Release number of selected component (if applicable):
gettext-0.16.1-8.fc7

How reproducible:
msghack --help
  
Actual results:
  File "/usr/bin/msghack", line 3
SyntaxError: Non-ASCII character '\xf8' in file /usr/bin/msghack on line 3, but
no encoding declared; see http://www.python.org/peps/pep-0263.html for details


Expected results:
Get the help or otherwise function correctly

Additional info:
The problem is simple, there is a Unicode character in the header crediting one
of the coders which crashes the tool in newer versions of Python.

I'm not sure if msghack is used much.  I use it mostly to empty PO files and
create POT file.  An alternate might be to extend the Translate Toolkit to do
the functions provided by msghack.

Comment 1 Dwayne Bailey 2007-07-31 12:40:29 UTC
Created attachment 160310 [details]
Fix for encoding

Comment 2 Jens Petersen 2007-08-01 07:29:56 UTC
Thanks for the fix!  Fixing first in Fedora devel gettext-0.16.1-9.fc8.
May backport it later to F7.




Note You need to log in before you can comment on or make changes to this bug.