Bug 250250 - After installation of pfmon: host kernel does not have perfmon support
After installation of pfmon: host kernel does not have perfmon support
Status: CLOSED DUPLICATE of bug 447621
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pfmon (Show other bugs)
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: William Cohen
: 250247 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2007-07-31 08:54 EDT by Per Lindahl
Modified: 2010-04-22 10:04 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-07-07 17:06:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Per Lindahl 2007-07-31 08:54:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en; rv: Gecko/20061201 Epiphany/2.18 Firefox/ (Ubuntu-feisty)

Description of problem:
After installing pfmon (pfmon-3.2-0.060926.4.el5) and libpfm (libpfm-3.2-0.060926.4.el5) when I then run pfmon I get :host kernel does not have perfmon support

When I check the kernel config file the "cat /boot/config-2.6.18-8.el5 |grep -i PERFMON" I get nothing. There should be a line saying "CONFIG_PERFMON=y" which isn't there. 

It has been a request from the performance team to have the availability of that tool on all RHEL 5 systems on i386 and x86_64 too since it's included in the distribution. Since we're not allowed to recompile the kernel since we need to be sure we are testing on the default kernel  we are currently not able to add the functionality for them.

As these packages are included in the distribution I guess that this is a bug.


Version-Release number of selected component (if applicable):
pfmon-3.2-0.060926.4.el5 kernel-2.6.18-8.el5

How reproducible:

Steps to Reproduce:
1. rpm -ivh pfmon-3.2-0.060926.4.el5.i386.rpm libpfm-3.2-0.060926.4.el5.i386.rpm
2.[root@localhost ~]# pfmon
host kernel does not have perfmon support

Same goes for x86_64 systems

Actual Results:
host kernel does not have perfmon support

Expected Results:
This package contains pfmon 3.x, a tool to monitor performance using
the Performance Monitor Unit (PMU). Pfmon can monitor
standalone programs or the entire system on both UP and SMP Linux systems.

Additional info:
Comment 1 William Cohen 2007-07-31 11:23:09 EDT
*** Bug 250247 has been marked as a duplicate of this bug. ***
Comment 2 William Cohen 2007-07-31 11:28:13 EDT
There is development on perfmon2 to provide support for architectures other than
ia64 supported in the original perfmon kernel support. However, need to have the
perfmon2 support for x86_64 and i386 merged with the upstream linux kernels
before backporting it to the Red Hat Enterprise Linux kernels.
Comment 3 William Cohen 2008-07-07 17:06:52 EDT

*** This bug has been marked as a duplicate of 447621 ***
Comment 4 Len Trigg 2010-04-21 23:18:18 EDT
The bug that this is marked as a duplicate of is not visible to the public. Has there been any resolution?
Comment 5 Per Lindahl 2010-04-22 04:02:26 EDT
Not that I know of.
But this is still interesting. Any chance of getting access to the bug that is currently unavailable?
Comment 6 William Cohen 2010-04-22 10:04:25 EDT
The summary of the 447621 is that RHEL6 support perf, the performance counter mechanism in the newer Linux kernels.


There is similar support in Fedora 12 with the installation of the perf RPM.

Note You need to log in before you can comment on or make changes to this bug.