Bug 250268 - s-c-k crashes upon startup (dump attached)
Summary: s-c-k crashes upon startup (dump attached)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-kickstart   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-31 15:21 UTC by Brad Smith
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-31 18:58:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Crash output (1.73 KB, text/plain)
2007-07-31 15:21 UTC, Brad Smith
no flags Details

Description Brad Smith 2007-07-31 15:21:10 UTC
Description of problem:
Just installed s-c-k. On first run and all subsequent runs, it starts, begins
reading repo information and then crashes. It appears to do this because it
can't get some metadata from the [development] repo even though enabled=0 for it. 

Version-Release number of selected component (if applicable):
system-config-kickstart-2.7.7-1.fc7

How reproducible:
Always


Steps to Reproduce:
1. Run s-c-k
  
Actual results:
crash

Expected results:
non-crash

Comment 1 Brad Smith 2007-07-31 15:21:11 UTC
Created attachment 160333 [details]
Crash output

Comment 2 Chris Lumens 2007-07-31 18:16:12 UTC
What repos do you have enabled and disabled?

Comment 3 Brad Smith 2007-07-31 18:51:02 UTC
Hmm... I had adobe and livna enabled in addition to the standard fedora and
updates repos. I disabled them, ran it and it works. Then I re-enabled them and
it still works. So either it was a temporary problem with one of the repos
(shouldn't it just start but not allow fancy package customization in that
case?) or the "reset" fixed it.

Comment 4 Chris Lumens 2007-07-31 18:58:35 UTC
Probably some temporary network or repo problem that went away between runs. 
You're right in that it should disable package selection if there are problems
instead of crashing, though.  It does a little bit of that but I need more
exception handling to catch this case.  I'll add that for a new version.


Note You need to log in before you can comment on or make changes to this bug.