Bug 250280 - rpm-build on ISO conflicts with RHEL 4.5 based installs
rpm-build on ISO conflicts with RHEL 4.5 based installs
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Suchý
Clifford Perry
Depends On:
  Show dependency treegraph
Reported: 2007-07-31 12:15 EDT by Miroslav Suchý
Modified: 2007-10-11 15:52 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat-4.2.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-10-11 15:52:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2007-07-31 12:15:51 EDT
Description of problem:
I have RHEL 4.5 and when I run ./install.pl --disconnected I got that rpm of
certain version is required (log is lost now - sorry).
I run 
up2date -i rpm-build 
(that was the one, which required rpm) and re-run ./install.pl --disconnected
I got 
ERROR: RPM dependency error.  The message was:
Dependencies should have already been resolved, but they are not.
Unresolved rpm dependencies:

Package antlr  2.7.2-3jpp_1rh requires jpackage-utils
Package stax-bea-1.0-2jpp_2rh requires jpackage-utils >= 0:1.5
Package jta-1.0.1-0.b.3jpp_1rh requires jpackage-utils >= 0:1.5
Package java-1.4.2-ibm- requires jpackage-utils >= 0:1.5.14
Package jisp2-2.5.1-3jpp requires jpackage-utils >= 0:1.5
Package xml-commons-1.0-0.b2.6jpp_2rh requires jpackage-utils >= 0:1.5
Package tomcat5-5.0.27-2jpp_1rh requires jpackage-utils >= 0:1.5.24
Package tanukiwrapper-3.1.2-4jpp_1rhn requires jpackage-utils >= 0:1.5
Package bouncycastle-1.27-1jpp requires jpackage-utils >= 0:1.5
Package ant-1.6.2-2jpp requires jpackage-utils >= 0:1.5
Package axis-1.1-2jpp_1rh requires jpackage-utils >= 0:1.5
Package javacc-3.2-1jpp_1rh requires jpackage-utils >= 0:1.5
Package xsdlib-2.2-0.20030225.2jpp requires jpackage-utils >= 0:1.5
Package log4j-1.2.8-7jpp_1rh requires jpackage-utils >= 0:1.5
Package jasper5-5.0.19-2jpp_2rh requires jpackage-utils >= 0:1.5.32

I run up2date -i jpackage-utils and everything work ok.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install RHEL 4.5
2. install satellite from
Comment 1 Clifford Perry 2007-07-31 15:48:28 EDT
jpackage-utils is part of the default @Base install for a RHEL 4 system - from
reviewing the comps file I saw - so not sure how it was not installed on your
system. Do you know how it did not get installed onto your system? (anaconda
install log?). 

rpm-build though is a known and continuing pain point for Satellite. Which is
why for Satellite 5.1 I have a series of bugs where we will fix ths issue. 

If we do choose to roll a new ISO, then we should upgrade the version of
rpm-build on it again. I am going to move this bug under 'rhn42maint' so that
if/when time for a 4.2.2 release comes along, we can make sure this is addressed
again (maybe following in the foot steps of 5.1). 

For 5.1 work - see:

1) rip the rpm packages out of the ISO
2) make the installer check to see if 'rpm-build' is installed, early on, and if
it is not, then exit saying please install
3) Add a note to the Satellite install guide, saying for 'rpm-build' to be
installed along with @base prior to Sat installation. 

[root@rlx-1-14 x]# mount | grep rhn-satellite
/root/rhn-satellite-4.2.1-4-redhat-linux-as-i386-4-embedded-oracle.iso on
/root/x type iso9660 (rw,loop=/dev/loop0)
[root@rlx-1-14 x]# pwd
[root@rlx-1-14 x]# find . | egrep -i 'rpm-build|jpackage-utils'
[root@rlx-1-14 x]# rpm -q jpackage-utils rpm-build
[root@rlx-1-14 x]# rpm -q --last jpackage-utils rpm-build
rpm-build-4.3.3-22_nonptl                     Wed 11 Jul 2007 08:35:05 PM EDT
jpackage-utils-1.7.3-1jpp.1.el4               Wed 11 Jul 2007 02:47:44 PM EDT
[root@rlx-1-14 x]# rpm -qa --last | egrep -C5 'jpackage-utils|rpm-build'
perl-DBI-1.47-5.rhel4                         Wed 11 Jul 2007 08:36:05 PM EDT
perl-DateTime-Locale-0.09-5.rhel4             Wed 11 Jul 2007 08:36:05 PM EDT
perl-XML-SAX-0.12-7                           Wed 11 Jul 2007 08:36:04 PM EDT
perl-XML-NamespaceSupport-1.08-9.rhel4        Wed 11 Jul 2007 08:36:04 PM EDT
perl-Params-Validate-0.74-3.rhel4             Wed 11 Jul 2007 08:36:04 PM EDT
rpm-build-4.3.3-22_nonptl                     Wed 11 Jul 2007 08:35:05 PM EDT
xorg-x11-xfs-6.8.2-1.EL.18                    Wed 11 Jul 2007 02:49:19 PM EDT
vixie-cron-4.1-47.EL4                         Wed 11 Jul 2007 02:49:18 PM EDT
quota-3.12-6.el4                              Wed 11 Jul 2007 02:49:18 PM EDT
pciutils-2.1.99.test8-3.4                     Wed 11 Jul 2007 02:49:18 PM EDT
nfs-utils-1.0.6-80.EL4                        Wed 11 Jul 2007 02:49:17 PM EDT
crash-4.0-3.9                                 Wed 11 Jul 2007 02:47:47 PM EDT
cracklib-2.8.9-1.3                            Wed 11 Jul 2007 02:47:46 PM EDT
ypbind-1.17.2-13                              Wed 11 Jul 2007 02:47:45 PM EDT
psacct-6.3.2-39.rhel4                         Wed 11 Jul 2007 02:47:45 PM EDT
ntsysv-                         Wed 11 Jul 2007 02:47:44 PM EDT
jpackage-utils-1.7.3-1jpp.1.el4               Wed 11 Jul 2007 02:47:44 PM EDT
grub-0.95-3.8                                 Wed 11 Jul 2007 02:47:44 PM EDT
logrotate-3.7.1-6.RHEL4                       Wed 11 Jul 2007 02:47:43 PM EDT
desktop-file-utils-0.9-3.el4                  Wed 11 Jul 2007 02:47:43 PM EDT
attr-2.4.16-3.1.el4                           Wed 11 Jul 2007 02:47:43 PM EDT
ttmkfdir-3.0.9-20.el4                         Wed 11 Jul 2007 02:47:41 PM EDT
[root@rlx-1-14 x]# grep -i jpackage-utils /usr/share/comps/i386/
comps.xml  .discinfo  hdlist     hdlist2
[root@rlx-1-14 x]# grep -i jpackage-utils /usr/share/comps/i386/comps.xml
      <packagereq type='default'>jpackage-utils</packagereq>
[root@rlx-1-14 x]# vi +/jpackage-utils /usr/share/comps/i386/comps.xml
[root@rlx-1-14 x]#
Comment 2 Miroslav Suchý 2007-08-01 07:56:07 EDT
I checked it. I install the system from adelton instant Xen machine and it is
missinng the jpackage-utils, where base RHEL45 have it. So only one problem is
Comment 9 Miroslav Suchý 2007-09-11 08:45:20 EDT
Cliff comments does not reached this bug, reposting:
error: Failed dependencies:
        rpm = 4.2.3-30_nonptl is needed by rpm-build-4.2.3-30_nonptl
[root@rlx-1-18 x]# rpm -q rpm
[root@rlx-1-18 x]# 

FAILS_QA - not part of this bug, since this was to fix it for RHEL 4.5 - but the
RHEL 3.9 also has same issue. 

Mirek - can we put newer RHEL 3 rpm RPM's into
rhn/satellite/updates-redhat-linux-as-i386-3/RPMS for 4.2.


FYI - RHEL 4.5 does now install correctly - so that part passed. just failing so
we can get the rhel 3.9 fixed as well in this bug. 

Comment 10 Miroslav Suchý 2007-09-11 10:26:12 EDT
I added rpm*-4.2.3-32_nonptl.i386.rpm packages and commited into CVS
/cvs/rhn/rhn/satellite/updates-redhat-linux-as-i386-3/RPMS/ in
satellite-4_2-branch branch.
Comment 13 Clifford Perry 2007-10-08 20:46:14 EDT
RHEL 3 and RHEL 4 4.2.2 ISO has updated (RHEL 4.5+ and RHEL 3.9+ rpm-build
packages on ISO). Moving to RELEASE_PENDING. 


Note You need to log in before you can comment on or make changes to this bug.