Bug 250300 - Default timeout causes connection timeouts against busy servers
Summary: Default timeout causes connection timeouts against busy servers
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rhnlib
Version: 4.5
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Pradeep Kilambi
QA Contact: Beth Nackashi
URL:
Whiteboard:
Depends On:
Blocks: 246627
TreeView+ depends on / blocked
 
Reported: 2007-07-31 17:43 UTC by Martin Poole
Modified: 2018-10-19 23:01 UTC (History)
1 user (show)

Fixed In Version: RHBA-2008-0777
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-24 20:06:48 UTC


Attachments (Terms of Use)
python test example (598 bytes, text/x-python)
2007-07-31 17:43 UTC, Martin Poole
no flags Details
server-side delay routine (246 bytes, application/x-cgi)
2007-07-31 17:45 UTC, Martin Poole
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0777 normal SHIPPED_LIVE rhnlib bug fix update 2008-07-23 17:18:12 UTC

Description Martin Poole 2007-07-31 17:43:50 UTC
Description of problem:

The addition of the default timeout of 30 seconds causes connection timeouts
against busy servers or those with many registered clients.

Version-Release number of selected component (if applicable):

2.1.1-3.el4

How reproducible:

Always against busy servers.

Steps to Reproduce:
1. Create secure server with 
2.
3.
  
Actual results:

# rhnreg_ks --activationkey=test-activation-key
Connection timed out on readline

Expected results:

No timeout.


Additional info:

The issue is with the DEFAULT_TIMEOUT in
/usr/lib/python2.3/site-packages/rhn/SSL.py and its use in connections.py.

Whilst a timeout of 30 seconds might not be unreasonable for the SSL connection
to take place it is not suitable for the ongoing connection. The socket timeout
should be reset to a more reasonable value once the SSL connection is in place.

Attached is a server-side cgi which just delays for a requested amount of time
and a small python script to exercise this cgi via the rhnlib code.

Comment 1 Martin Poole 2007-07-31 17:43:55 UTC
Created attachment 160345 [details]
python test example

Comment 2 Martin Poole 2007-07-31 17:45:07 UTC
Created attachment 160346 [details]
server-side delay routine

Comment 3 RHEL Product and Program Management 2007-11-03 01:35:43 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 RHEL Product and Program Management 2007-11-29 04:16:53 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 12 errata-xmlrpc 2008-07-24 20:06:48 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0777.html


Note You need to log in before you can comment on or make changes to this bug.