Bug 250302 - confusing nsupdate errors
Summary: confusing nsupdate errors
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Adam Tkac
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-31 17:49 UTC by Curtis Doty
Modified: 2013-04-30 23:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-01 12:10:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Curtis Doty 2007-07-31 17:49:44 UTC
An old ddns script that worked fine on FC6/bind-9.3.4 now fails on F7/9.4.1 with
this error:

mem.c:866: INSIST((((ctx->pools).head == ((void *)0)) ? isc_boolean_true :
isc_boolean_false)) failed.

I *think* this is because it can no longer handle leading blank lines on stdin.
In my case, it was an easy-to-read bash script using a here string:

        nsupdate -k $1 <<<"
                server $DDNSSERVER
                zone $DDNSZONE
                update delete $LHOSTNAME A
                update add $LHOSTNAME $TTL A $IPADDR
                send
        "

The confusing and misleading error is the bug.

Comment 1 Adam Tkac 2007-08-01 12:10:51 UTC
(In reply to comment #0)
> I *think* this is because it can no longer handle leading blank lines on stdin.

> The confusing and misleading error is the bug.

It's memory-leak checking (if ctx->pools->head isn't NULL that means some memory
have been allocated but not dealocated). It's low-severity bug because records
are updated as expected (yes, in the end of nsupdate is some memory isn't
dealocated but kernel take care about it ;) ). Already fixed in rawhide. I don't
think that this has to be fixed in F7. If you want fix in F7, please reopen.

Regards, Adam



Comment 2 Curtis Doty 2007-08-01 16:38:02 UTC
Agreed. The F7 workaround is to clean up the input and thus appease nsupdate's
persnicketiness.


Note You need to log in before you can comment on or make changes to this bug.