Bug 250324 - adminserver: port to HP-UX
adminserver: port to HP-UX
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Admin (Show other bugs)
1.1.0beta
All Linux
low Severity low
: ---
: ---
Assigned To: Rich Megginson
Viktor Ashirov
:
Depends On:
Blocks: 240316 FDS1.1.0
  Show dependency treegraph
 
Reported: 2007-07-31 16:22 EDT by Rich Megginson
Modified: 2015-12-07 11:33 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:33:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diffs (12.83 KB, patch)
2007-07-31 16:22 EDT, Rich Megginson
no flags Details | Diff
diffs (17.25 KB, patch)
2007-07-31 18:28 EDT, Rich Megginson
no flags Details | Diff
cvs commit log (2.53 KB, text/plain)
2007-08-01 14:15 EDT, Rich Megginson
no flags Details
diffs for adminutil (2.92 KB, patch)
2007-08-06 15:13 EDT, Rich Megginson
no flags Details | Diff
cvs commit log - adminutil (1.82 KB, text/plain)
2007-08-06 15:55 EDT, Rich Megginson
no flags Details

  None (edit)
Description Rich Megginson 2007-07-31 16:22:05 EDT
There are several problems with running the Admin Server on HP-UX
Comment 1 Rich Megginson 2007-07-31 16:22:05 EDT
Created attachment 160354 [details]
diffs
Comment 2 Rich Megginson 2007-07-31 18:28:09 EDT
Created attachment 160376 [details]
diffs
Comment 3 Noriko Hosoi 2007-07-31 19:53:26 EDT
Your fixes look good to me.

BTW, user nobody has been a pet peeve for me on HP-UX...  (I've been always
changed it to root when install the server on HP-UX)  So, nobody.nogroup is to
be accepted?  I tried this on hound as root:
# uname -a
HP-UX hound B.11.23 U ia64 0379113248 unlimited-user license
# touch test_file
# ls -l test_file
-rw-r--r--   1 root       sys              0 Jul 31 16:51 test_file
# chown nobody test_file
test_file: Invalid argument
# chgrp nogroup test_file
test_file: Invalid argument
# chown nhosoi test_file
# ls -l test_file
-rw-r--r--   1 nhosoi     sys              0 Jul 31 16:51 test_file

Are there any thing to configure on hound before using nobody.nogroup?
Comment 4 Nathan Kinder 2007-07-31 20:19:34 EDT
The changes look good.

Is adminutil_libdir no longer necessary in the sed command in Makefile.am?
Comment 5 Rich Megginson 2007-08-01 11:31:21 EDT
(In reply to comment #3)
> Your fixes look good to me.
> 
> BTW, user nobody has been a pet peeve for me on HP-UX...  (I've been always
> changed it to root when install the server on HP-UX)  So, nobody.nogroup is to
> be accepted?  I tried this on hound as root:
> # uname -a
> HP-UX hound B.11.23 U ia64 0379113248 unlimited-user license
> # touch test_file
> # ls -l test_file
> -rw-r--r--   1 root       sys              0 Jul 31 16:51 test_file
> # chown nobody test_file
> test_file: Invalid argument
> # chgrp nogroup test_file
> test_file: Invalid argument
> # chown nhosoi test_file
> # ls -l test_file
> -rw-r--r--   1 nhosoi     sys              0 Jul 31 16:51 test_file
> 
> Are there any thing to configure on hound before using nobody.nogroup?

I don't know.  Some operating systems do not like to allow you to use
nobody:nogroup for programs.  On linux, most all daemons actually create a new
user.  We may have to do this for ds (abartlet suggested we create a dirsrv user
in our spec file).  We need to ask HP what they would like us to do - use root
for everything, or perhaps they already have a user they use for this purpose?
Comment 6 Rich Megginson 2007-08-01 13:18:43 EDT
(In reply to comment #4)
> The changes look good.
> 
> Is adminutil_libdir no longer necessary in the sed command in Makefile.am?

No.  The only place we use it is in LIBPATH.
Comment 7 Rich Megginson 2007-08-01 14:15:56 EDT
Created attachment 160446 [details]
cvs commit log

Reviewed by: nkinder, nhosoi (Thanks!)
Files: see diff
Branch: HEAD
Fix Description: 1) We need the same --enable-bundle option as ldapserver, so
that adminserver knows where to find the shared libraries at runtime.  2) The
adminserver Makefile constructs the LIBPATH for scripts to use.  Use this
consistently
3) Need to use -lpthread before -lc
4) Use same --enable-debug as ldapserver
5) HP-UX has group "nogroup" instead of "nobody"
6) Use same libtool gcc hack as ldapserver uses
7) mod_deflate is not supported on HP-UX
Doing a DEBUG build caused breakage due to missing ereport.  Instead, just use
PR_ASSERT for NS_ASSERT.
HAVE_STRFTIME is now defined in config.h.
Platforms tested: HP-UX 11.23 IPF 64bit
Flag Day: Yes - autotool file changes
Doc impact: no
Comment 8 Rich Megginson 2007-08-06 15:13:39 EDT
Created attachment 160765 [details]
diffs for adminutil
Comment 9 Rich Megginson 2007-08-06 15:55:01 EDT
Created attachment 160767 [details]
cvs commit log - adminutil

Reviewed by: nkinder (Thanks!)
Files: see diff
Branch: HEAD
Fix Description: On HP-UX and the other bundled platforms, adminutil needs to
know where to find its property files.	We have to set the env. var.
ADMINUTIL_CONF_DIR to the parent directory of the property directory.
Platforms tested: HP-UX 11.23 IPF 64bit
Flag Day: Yes, autotool file changes.
Doc impact: no

Note You need to log in before you can comment on or make changes to this bug.