Bug 250326 - efibootmgr uses lower case hex values which violates EFI spec
efibootmgr uses lower case hex values which violates EFI spec
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: elilo (Show other bugs)
4.5
ia64 Linux
high Severity high
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-31 16:28 EDT by Doug Chapman
Modified: 2010-10-22 13:04 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2007-0664
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:03:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch taken directly from upstream efibootmgr (4.84 KB, patch)
2007-07-31 16:28 EDT, Doug Chapman
no flags Details | Diff

  None (edit)
Description Doug Chapman 2007-07-31 16:28:45 EDT
Description of problem:

From issue-tracker:
On my SandDune (Superdome/sx2000), I have a _lot_ of disks, a lot of networking
cards, and a lot of various Linux installs.  I have 10 bootable entries, as follows:

[root@worm0 ~]# efibootmgr
BootCurrent: 0008
Timeout: 10 seconds
BootOrder: 0000,0005,0004,0008,0009,0003,0001,0007,0002,0006
Boot0000* EFI Shell
Boot0001* Gbit Boot NIC
Boot0002* USB Optical/DVD drive
Boot0003* 10GigE NIC Boot
Boot0004* RHEL5 Server
Boot0005* RHEL4u4 AS
Boot0006* SCSI Optical/DVD Drive
Boot0007* Smart Setup from USB/HDD
Boot0008* RHEL4.5 AS (snap#5)
Boot0009* SLES10
[root@worm0 ~]#

Now the problem is that if I install a NEW copy of RHEL4.5 (snapshot 5), the
installer creates an entry named "Boot000a" (with a lower-case 'A').  If you
boot to RHEL5 and run "efibootmgr", it complains about the lower-case 'A' and
suggests the user fix that by changing the boot entry via EFI.

The problem with this: EFI doesn't recognize it.  So, RHEL4.5 needs to ensure
that Hex-digits a-f are UPPER-CASE when it creates boot entries.


It appears this was fixed upstream and is already fixed in RHEL5.  I will
provide a patch.


Version-Release number of selected component (if applicable):



How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2007-07-31 16:28:45 EDT
Created attachment 160355 [details]
patch taken directly from upstream efibootmgr
Comment 2 Fabio Olive Leite 2007-07-31 18:03:54 EDT
Exception request will be filed ASAP.
Comment 3 RHEL Product and Program Management 2007-07-31 18:04:31 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 10 errata-xmlrpc 2007-11-15 11:03:44 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0664.html

Note You need to log in before you can comment on or make changes to this bug.