Bug 250339 - mc refuses to open FTP connection after timeout to the same machine
mc refuses to open FTP connection after timeout to the same machine
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-31 18:03 EDT by David Kovalsky
Modified: 2014-03-31 19:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 22:02:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kovalsky 2007-07-31 18:03:40 EDT
Version-Release number of selected component (if applicable):
mc-4.6.1a-45.20070124cvs.fc7

How reproducible:
always

Steps to Reproduce:
1. start mc, F9 -> FTP link ...
2. enter user@12.12.123.1 [ip address obviosly modified :-)]
3. enter password when asked
4. select directory (Download in my case), enter
5. F5 to copy whole directory
6. wait for the connection to timeout after the copy is finished

This is where the fun stuff begins:
F9->FTP link 
Without beeing prompted for anything I get an error in red box saying:
Cannot chdir to "/#ftp:user@12.12.123.1/Download"
Permission denied (13)

When I hit enter the usual FTP connect dialog appears. But entering the same
values as before doesn't work this time - "user@12.12.123.1" -> enter -> error
Cannot chdir to /#ftp:12.12.123.1

Making connection to a different address seems to work.  

I've tried many different things, but the only way to reconnect to the server
seems to be restarting mc.
Comment 1 David Kovalsky 2007-07-31 18:10:46 EDT
FTP server is BulletProof, version v2.3.1 build 26 2k4
http://www.bpftpserver.com/
Comment 2 Bug Zapper 2008-05-14 09:47:36 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 David Kovalsky 2008-05-14 10:55:39 EDT
I've just tried reproducing this on F8 with mc-4.6.1a-50.20070604cvs.fc8, but no
luck. 

Either is has been fixed in the meantime or is specific BPFTP server, which I
don't have access to anymore. 

Comment 4 Bug Zapper 2008-06-16 22:02:36 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.