Bug 25040 - upgrading of perl rpm breaks previously existing installation of perl rpm
upgrading of perl rpm breaks previously existing installation of perl rpm
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: perl (Show other bugs)
6.2
i386 Linux
high Severity high
: ---
: ---
Assigned To: Warren Togami
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-26 13:30 EST by Paul Lussier
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-28 02:56:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Lussier 2001-01-26 13:30:06 EST
When upgrading from perl-5.00503-10.i386.rpm which comes with RH6.2
to perl-5.00503-12.i386.rpm which is the latest update of perl for the 6.2
release of RH Linux, any localized customizations get removed.

For example, if you've installed any perl modules, which typically get
installed in the /usr/lib/perl5/site_perl/ hierarchy, and upgrade (using
the -U flag to rpm) perl, everything under this hierarchy gets deleted.

This is broken behavior and should be fixed.  It is completely
unacceptable to cripple an infrastructure dependant upon installed perl
modules when all you intend to do is upgrade the core perl installation
itself.

This behavior should be fixed a.s.a.p.!

Thanks.
Comment 1 Paul Lussier 2001-12-06 16:32:26 EST
Hmmm,

Let's see:

Bug logged: 2001-01-26 13:30:06
Priority:   High
Status:     NEW

Something doesn't quite make sense here.  It was logged almost 11 months ago,
has priority of "High", yet it still has a status of "NEW".

It you guys 11 months to notify me that you've done nothing?

Outstanding!  I suppose I ought to be greatfull, since MS doesn't even
acknowledge that they have bugs :)

Merry Christmas, and Happy New Year.

P.S.  Please send me another update next year sometime :)
Comment 2 Paul Lussier 2001-12-06 16:35:52 EST
Whoops, pipe last update through sed 's/greatful/grateful/g' :)

Seeya,
Paul
Comment 3 Chip Turner 2001-12-19 03:46:42 EST
rpm -Uvh removed your entire site_perl directory, removing modules you had
installed?  RPM won't delete files it doesn't know about.  I will try to
reproduce in a clean 6.2 environment, but are you certain there wasn't something
different in your setup?

and sorry, the update is this year :)

Note You need to log in before you can comment on or make changes to this bug.