Bug 250403 - Refers to Pidgin as 'Gaim'
Refers to Pidgin as 'Gaim'
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nautilus-sendto (Show other bugs)
5.0
All Linux
high Severity high
: rc
: ---
Assigned To: Bastien Nocera
desktop-bugs@redhat.com
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-01 09:06 EDT by Johnny Hughes
Modified: 2014-01-21 17:59 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
nautilus-sendto 1.0 in Red Hat Enterprise Linux 5.0 adds the ability to send to Bluetooth devices, better Pidgin integration, and a number of user interface fixes.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 03:57:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Johnny Hughes 2007-08-01 09:06:56 EDT
+++ This bug was initially created as a clone of Bug #242288 +++

Description of problem: When the Nautilus Integration plugin is enabled in
Pidgin, Pidgin is referred to as 'Gaim' in the nautilus-sendto window.
Especially given that Gaim was renamed for legal reasons, this should be fixed.


Version-Release number of selected component (if applicable):
nautilus-sendto-0.10-4.fc7


How reproducible: Always


Steps to Reproduce:
1. Enable Nautilus Integration plugin is pidgin
2. Right click on a file or folder in nautilus and select send to
3. Click the combo box
  
Actual results: Mentions 'Gaim'


Expected results: Should mention 'Pidgin'

-- Additional comment from madcat@mymadcat.com on 2007-06-04 10:21 EST --
Well, src/plugins/gaim.c should be altered at line 228, as well as every po file
(actually a good sed could do the job)

-- Additional comment from zaki@star2000.net on 2007-07-25 09:20 EST --
Despite that pidgin has replaced gaim, I get this:

[root@localhost ~]# rpm -Va --nofiles
Unsatisfied dependencies for nautilus-sendto-0.7-5.fc6.i386: libgaim.so.0

So the package nautilus-sendto is still requiring libgaim.so.0 even after it was
replaced by pidgin

=============================================================================

Actually there is a problem with nautilus-sendto requiring libgaim.so.0 ...

The nautilus-sendto included will not compile against pidgin without modification.
Comment 1 Johnny Hughes 2007-11-21 05:35:24 EST
The libgaim.so.0 issue is very bad, as nautilus-sendto can not be installed if
not done by anaconda (which ignores the missing dependancy on libgaim.so.0).

RPM will not ignore it without a force, however.
Comment 2 Johnny Hughes 2007-11-21 05:36:58 EST
I shifted the urgency to high as this causes the el5 repo to not have closure.
Comment 3 Johnny Hughes 2007-12-03 03:24:26 EST
This is a fairly serious issue ... as the RHEL-5 tree does not have repo closure
and you can't install nautilus-sendto via yum or up2date.

Is this bug at least going to be acknowledged?
Comment 4 Akemi Yagi 2007-12-18 15:29:50 EST
This bug really needs to be taken care of promptly.  When we attempt to
groupinstall "GNOME Desktop Environment" it fails because nautilus-sendto is in
that group.
Comment 5 Johnny Hughes 2008-02-01 07:29:11 EST
since this does not seem to be moving forward (but it is rather important giving
the problem with groupinstalls), the following SRPM seems to work on el5 (at
least it builds and installs properly on el5 i386 and x86_64):

http://people.centos.org/~hughesjr/nautilus-sendto/

Could someone please review this and if it works can we get it implemented so we
can have a main repository with repo closure.

Comment 6 Ralph Angenendt 2008-02-13 15:28:07 EST
Any news on that one? It is getting tedious to explain to people why there is
some weird dependency on libgaim.so.0 even if there is no gaim in the
distribution ...
Comment 7 Ralph Angenendt 2008-03-03 15:33:25 EST
Three weeks later ...

Any news? It's just a rebuild away with correct dependencies. 
Comment 8 Bastien Nocera 2008-03-03 16:01:05 EST
It's on course for RHEL 5.3.0. Contact your support representatives if you need
a fix before then.
Comment 11 Bill Nottingham 2008-06-27 14:55:50 EDT
Note that the RHEL 5 repository *does* have repo closure - the dependency issue
seems to only exist in non-RHEL repositories.
Comment 12 Johnny Hughes 2008-06-29 12:31:53 EDT
The RHEL-5 repo does not have closure ... nautlius-sendto in production right
now requires libgaim.so.0 ... that file is provided by gaim which is obsoleted
by pidgin.

if something SHOWS closure, it is a bug BECAUSE that process does not take into
account obsoletes and counts gaim as providing the require ... however gaim can
not be installed.

Anaconda ignores the libgaim.so.0 requirement and happily installs
nautilus-sendto even though libgaim.so.0 does not exist.  Using yum to install
it later will not work due to the obsoletes. 

 
Comment 13 Bill Nottingham 2008-07-03 14:09:19 EDT
(In reply to comment #12)
> The RHEL-5 repo does not have closure ... nautlius-sendto in production right
> now requires libgaim.so.0 ... that file is provided by gaim which is obsoleted
> by pidgin.

I'm sorry, but you are mistaken. I've double and triple-checked the RHEL 5 build
of nautilus-sendto-0.7-5.fc6 (which is also the 5.1/5.2 version, the package
hasn't changed). They do not require libgaim.so.0.

Perhaps you are using a rebuild, and the issue is in that rebuild?
Comment 14 Bryan L. Gay 2008-07-17 15:20:37 EDT
If you do a base install, no X, then try to yum groupinstall the X Windows and
Gnome Desktop Environment, you get this dependency error. This is a common
problem with datacenter hosted customers using builds that do not include X by
default who them need to install X and gnome.

I've reproduced this consistently.
Comment 15 Johnny Hughes 2008-07-17 16:50:36 EDT
(in reply to #c13)
You are correct ... the RHEL5 (actually fc6) version somehow built a gaim plugin
that was not linked against libgaim.so.  That would have made it be broken if
gaim still existed.  So I guess that that part of the problem only happens if
you build nautilus-sendto against RHEL and not FC6.

Comment 16 RHEL Product and Program Management 2008-07-21 19:10:11 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 17 Shmuel Protter NDS Israel 2008-07-28 08:30:58 EDT
This is easy to work around

yum -y groupinstall "GNOME Desktop Environment" --exclude nautilus-sendto

Done.

Okay its a bug but we'll live through it.
Comment 23 Bastien Nocera 2009-01-23 09:36:13 EST
Release note added. If any revisions are required, please set the 
"requires_release_notes" flag to "?" and edit the "Release Notes" field accordingly.
All revisions will be proofread by the Engineering Content Services team.

New Contents:
nautilus-sendto 1.0 in Red Hat Enterprise Linux 5.0 adds the ability to send to Bluetooth devices, better Pidgin integration, and a number of user interface fixes.
Comment 31 errata-xmlrpc 2009-09-02 03:57:04 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0916.html

Note You need to log in before you can comment on or make changes to this bug.