Bug 250409 - When an existing LV with dash (hyphen) in name is selected for use, installation ends with traceback
Summary: When an existing LV with dash (hyphen) in name is selected for use, installat...
Status: CLOSED DUPLICATE of bug 186439
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-01 13:43 UTC by Jan Pazdziora
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 15:27:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traceback. (77.32 KB, text/plain)
2007-08-01 13:43 UTC, Jan Pazdziora
no flags Details

Description Jan Pazdziora 2007-08-01 13:43:20 UTC
Description of problem:

I have a system where LVs have dashes in their names. I've created (using
lvcreate new LV root-f7-64). The installation failed with traceback with error
message

No such file or directory: '/dev/mapper/vg0-root-fc7-64'

Anaconda should douple the dashes and use path /dev/mapper/vg0-root--f7--64.

Version-Release number of selected component (if applicable):

anaconda-11.2.0.66-1

How reproducible:

Daterministic.

Steps to Reproduce:
1. Have a preexisting LV with name that contains dash.
2. Try to install Fedora and place the root partition on that LV.
  
Actual results:

Traceback.

Expected results:

No traceback, installation running alright.

Additional info:

Anaconda allowed me to select that LV and did not complain that its name would
be unusable. Now, I know that I cannot create new LV with dash in anaconda. But
that restriction should probably be removed and proper handling of dashed LVs added.

Comment 1 Jan Pazdziora 2007-08-01 13:43:21 UTC
Created attachment 160410 [details]
Traceback.

Comment 2 Chris Lumens 2007-08-15 15:27:40 UTC

*** This bug has been marked as a duplicate of 186439 ***


Note You need to log in before you can comment on or make changes to this bug.