Bug 250439 - conga is unable to delete snapshot volumes
Summary: conga is unable to delete snapshot volumes
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga (Show other bugs)
(Show other bugs)
Version: 5.1
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Ryan McCabe
QA Contact:
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-01 16:26 UTC by Corey Marthaler
Modified: 2009-04-16 22:59 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 21:56:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0196 normal SHIPPED_LIVE conga bug-fix and enhancement update 2009-01-20 16:06:02 UTC

Description Corey Marthaler 2007-08-01 16:26:32 UTC
Description of problem:
The reason is because before deleting any lv, conga attempts to deactivate it (a
very noble gesture). The problem with that is snapshots can't have their
activation state changed. as it follows the origin volume's state. So in the
case of snapshot deletion, conga is just going to have to force delete it
without the deactivation attempt. 

Version-Release number of selected component (if applicable):
luci-0.10.0-3.el5
ricci-0.10.0-3.el5

How reproducible:
everytime

Comment 1 RHEL Product and Program Management 2007-10-16 03:51:45 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 RHEL Product and Program Management 2007-10-31 15:42:46 UTC
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request. 

Comment 6 Brian Brock 2008-12-16 23:40:15 UTC
verified, conga seems to be doing the right thing

Comment 8 errata-xmlrpc 2009-01-20 21:56:30 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0196.html


Note You need to log in before you can comment on or make changes to this bug.