Bug 25050 - rpm-4.0-4.3 detects no signatures on any package.
rpm-4.0-4.3 detects no signatures on any package.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
alpha Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-26 17:36 EST by Gregory McLean
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-26 17:36:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gregory McLean 2001-01-26 17:36:29 EST
On the alpha running rpm to verify a packages integrity is not possible as
rpm fails to find any signatures.

Official RPM from ftp.redhat.com

rpm -vv -K XFree86-100dpi-fonts-4.0.2-1.i386.rpm 
D: No signature
XFree86-100dpi-fonts-4.0.2-1.i386.rpm: No signature available

One generated and signed on the alpha:
 rpm -vv -K grip-2.95-2.alpha.rpm 
D: No signature
grip-2.95-2.alpha.rpm: No signature available

Checking same packages on an Intel box shows the packages are signed:
(or have at least an MD5 sum)

rpm -vv --checksig XFree86-100dpi-fonts-4.0.2-1.i386.rpm 
D: New Header signature
D: Signature size: 100
D: Signature pad : 4
D: sigsize         : 104
D: Header + Archive: 1274462
D: expected size   : 1274462
XFree86-100dpi-fonts-4.0.2-1.i386.rpm:
MD5 sum OK: 806b5b0422877eb03cdca81792562897

 rpm -vv -K grip-2.95-2.alpha.rpm 
D: New Header signature
D: Signature size: 366
D: Signature pad : 2
D: sigsize         : 368
D: Header + Archive: 240432
D: expected size   : 240432
grip-2.95-2.alpha.rpm:
MD5 sum OK: ef544b423a954d3dad8b4bfeb7a59952
gpg: Warning: using insecure memory!
gpg: Signature made Wed 17 Jan 2001 07:25:20 PM EST using ELG key ID E94D1363
gpg: Good signature from "Gregory McLean <gregm@gxsnmp.org>"
gpg:                 aka "Gregory McLean <gregm@comstar.net>"
gpg:                 aka "Gregory McLean <gregm@gnu.org>"
gpg:                 aka "Gregory McLean (Work Identity) <gmclean@globix.net>"

This prevents things like up2date from verifying packages and brings into
question the packages downloaded.
Comment 1 Jeff Johnson 2001-01-31 09:41:23 EST
This is gcc miscompilink rpm. The gcc bug has been fixed in gcc-2.96-60
(although you
want to use gcc-2.96-70 or later because of another bug) IIRC, and there are
attempts to
avoid the problem in rpm-4.0.1 and later. You can get rpm-4.0.1 at the moment
from
	ftp://ftp.rpm.org/pub/rpm/test-4.0.1

Note You need to log in before you can comment on or make changes to this bug.