Bug 250526 - adminutil: should not link against libplds or libsoftokn
adminutil: should not link against libplds or libsoftokn
Product: 389
Classification: Community
Component: Admin (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Rich Megginson
Orla Hegarty
Depends On:
Blocks: 240316 FDS1.1.0
  Show dependency treegraph
Reported: 2007-08-01 21:05 EDT by Rich Megginson
Modified: 2008-01-03 13:02 EST (History)
0 users

See Also:
Fixed In Version: 1.1.4-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-02 22:41:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
diffs (1.79 KB, patch)
2007-08-01 21:05 EDT, Rich Megginson
no flags Details | Diff
cvs commit log (1.43 KB, text/plain)
2007-08-01 23:18 EDT, Rich Megginson
no flags Details

  None (edit)
Description Rich Megginson 2007-08-01 21:05:07 EDT
The dependency on libplds and libsoftokn causes link failures with adminserver.
 I don't think we need these dependencies, so they should be removed.
Comment 1 Rich Megginson 2007-08-01 21:05:07 EDT
Created attachment 160485 [details]
Comment 2 Noriko Hosoi 2007-08-01 21:25:19 EDT
Looks good to me.
Comment 3 Rich Megginson 2007-08-01 23:18:46 EDT
Created attachment 160493 [details]
cvs commit log

Reviewed by: nhosoi (Thanks!)
Files: see diff
Branch: HEAD
Fix Description: This causes problems for apps that link against adminutil. 
adminutil does not need these libraries.
Platforms tested: RHEL4
Flag Day: no
Doc impact: no
Comment 4 Fedora Update System 2007-08-02 22:41:52 EDT
adminutil-1.1.4-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.