Bug 250530 - Use option "-p" with relative path can't record the ntpd process ID
Use option "-p" with relative path can't record the ntpd process ID
Status: CLOSED DUPLICATE of bug 242925
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ntp (Show other bugs)
5.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-01 21:38 EDT by zhangxiliang
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-07 04:48:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
the patch to the ntpd manpage for "-p" (524 bytes, patch)
2007-08-01 21:38 EDT, zhangxiliang
no flags Details | Diff

  None (edit)
Description zhangxiliang 2007-08-01 21:38:50 EDT
1.Summary:
  Use option "-p" with relative path can't record the ntpd process ID.

2.Version-Release of Selected Component:
  ntp-4.2.2pl-5.el5
 
3.Description of Problem: 
  If use this command with option "-p pidfile", the "pidfile" cannot record the
ntpd process ID successfully.

4.How reproducible:
  100%.
 
5.Step to Reproduce:
  1, execute command "service ntpd stop"
  2, set ip 192.168.0.1
  3, execute command "touch pidfile"
  4, execute command "echo "server 127.127.1.0" > ntp.conf"
  5, execute command "cp -f ntp.conf /etc"
  6, execute command "ntpd -p pidfile"
  7, confirm the pidfile contains process id information.
  
6.Actual results:
  Use option "-p pidfile" cannot find any process id information in the pidfile.

7.Expected results:
  Use option "-p pidfile" can record the ntpd process ID in the pidfile.
Comment 1 zhangxiliang 2007-08-01 21:38:50 EDT
Created attachment 160488 [details]
the patch to the ntpd manpage for "-p"
Comment 2 Miroslav Lichvar 2007-08-07 04:48:24 EDT

*** This bug has been marked as a duplicate of 242925 ***

Note You need to log in before you can comment on or make changes to this bug.