Bug 250531 - The "value" of "-m dscp -dscp" for iptables command can be set with [0~64]
The "value" of "-m dscp -dscp" for iptables command can be set with [0~64]
Status: CLOSED DUPLICATE of bug 239383
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iptables (Show other bugs)
5.0
All Linux
low Severity high
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-01 21:56 EDT by zhangxiliang
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 06:39:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the patch to the iptables manpage for "--dscp" (580 bytes, patch)
2007-08-01 21:56 EDT, zhangxiliang
no flags Details | Diff

  None (edit)
Description zhangxiliang 2007-08-01 21:56:36 EDT
1.Summary:
  The "value" of "-m dscp -dscp" for iptables command can be set with [0~64].

2.Version-Release of Selected Component:
  iptables-1.3.5-1.2.1
 
3.Description of Problem: 
  Use option "-m dscp -dscp value" can match 6 bit DSCP field within the TOS
field in the IP header against a valid numeric value which is 0~32.
  But in fact, the option can still match 2^6 bit DSCP field. The range is 0~64.

4.How reproducible:
  100%.
 
5.Step to Reproduce:
  1. iptables -A INPUT -m dscp --dscp 33
  2. iptables -L INPUT | grep "DSCP match 0x21"

6.Actual results:
  The test case will display "FAIL"

7.Expected results:
  The test case will display "PASS"
Comment 1 zhangxiliang 2007-08-01 21:56:36 EDT
Created attachment 160490 [details]
the patch to the iptables manpage for "--dscp"
Comment 2 zhangxiliang 2007-08-01 22:08:29 EDT
Comment on attachment 160490 [details]
the patch to the iptables manpage for "--dscp"

>diff -ru iptables-1.3.5.org/extensions/libipt_dscp.man iptables-1.3.5/extensions/libipt_dscp.man
>--- iptables-1.3.5.org/extensions/libipt_dscp.man	2007-08-01 20:29:03.000000000 +0800
>+++ iptables-1.3.5/extensions/libipt_dscp.man	2007-08-01 20:30:09.000000000 +0800
>@@ -2,7 +2,7 @@
> IP header.  DSCP has superseded TOS within the IETF.
> .TP
> .BI "--dscp " "value"
>-Match against a numeric (decimal or hex) value [0-32].
>+Match against a numeric (decimal or hex) value [0-63].
> .TP
> .BI "--dscp-class " "\fIDiffServ Class\fP"
> Match the DiffServ class. This value may be any of the
Comment 3 Thomas Woerner 2007-10-02 06:39:48 EDT

*** This bug has been marked as a duplicate of 239383 ***

Note You need to log in before you can comment on or make changes to this bug.