Bug 250549 - Rocket Raid 2300 Drivers wont make,
Rocket Raid 2300 Drivers wont make,
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: make (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Petr Machata
Fedora Extras Quality Assurance
http://www.highpoint-tech.com/USA/bio...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-02 03:18 EDT by big_green_jelly_bean
Modified: 2015-05-04 21:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 22:04:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description big_green_jelly_bean 2007-08-02 03:18:51 EDT
Dam having the following error when installing the
http://www.highpoint-tech.com/USA/bios_rr2300.htm Linux Driver at the end. I was
able to install this on the initial instal, but I am unable to install it after
I upgraded, thus it breaks my last RAID 5 array (luckily this didnt contain
system files, just the files for serving)

    [root@Beast linux]# ls
    config.c Makefile
    [root@Beast linux]# make
    make[1]: Entering directory `/usr/src/kernels/2.6.22.1-27.fc7-i686'
    make[2]: *** No rule to make target `/tmp/rr231x/osm/linux/os_linux.o',
needed by `/tmp/rr231x/product/rr2310pm/linux/.build/os_linux.o'. Stop.
    make[1]: *** [_module_/tmp/rr231x/product/rr2310pm/linux/.build] Error 2
    make[1]: Leaving directory `/usr/src/kernels/2.6.22.1-27.fc7-i686'
    make: *** [rr2310_00.ko] Error 2


The following is what I did in the past (Im currently stuck on the MAKE step)...


    1. yum install kernel-devel
    2. download source
    3. unpack to a temp dir such as
/home/GreenJelly/temp/rr231x_0x-linux-src-v2.0/product/rr2310pm/linux
    4. cd to that dir and type: make
    5. become root in terminal (su --login) note: use su - or su -l or su
--login DO NOT only use "su"
    6. as root: cd
/home/GreenJelly/temp/rr231x_0x-linux-src-v2.0/product/rr2310pm/linux
    7. cp rr2310_00.ko /lib/modules/'uname -r'/kernel/drivers/scsi
    8. cd /lib/modules/'uname -r'/kernel/drivers/scsi
    9. chmod 744 rr2310_00.ko
    10. depmod -ae
    11. reboot system


Other people with the 2.6.22.1-27/fc7 have been able to make this work.

I have tried using yum to reinstall all of the current applications including
the kernel, kernel-devel, and anything else i can find. I have found this error
mentioned multiple times when I google " *** No rule to make target" but am
unable to understand or apply the information given... please can someone help?

My last option is to re-install the system, but I am currently transfering files
off the first mirror drive (music and video) to another computer with an ETA of
36 HOURS!
Comment 1 big_green_jelly_bean 2007-08-02 03:21:18 EDT
I have re-installed, replaced motherboards, and have done everything I can to
try and solve this issue.  Days on IRC freenode looking for a solution, and none
was found...

Contacting Highpoint about this issue though finding difficult to get answers,
as with the irc
Comment 2 big_green_jelly_bean 2007-08-02 12:59:21 EDT
Contacted Highpoint, they say this is a known problem with the drivers on 2.6.2x
linux versions.  They stated it has to do with a change in the directory
structure of the kernel.  They are working on a fix.  I will report when they
fix it.
Comment 3 Ignacio Vazquez-Abrams 2007-08-02 13:17:07 EDT
I've tried building the driver in question, and here's what I get:

[ignacio@ignacio linux]$ make KERNELDIR=/usr/src/kernels/2.6.22.1-41.fc7-i686/
make[1]: Entering directory `/usr/src/kernels/2.6.22.1-41.fc7-i686'
make[2]: *** No rule to make target
`/home/ignacio/work/software/source/rr231x_0x-linux-src-v2.0/osm/linux/os_linux.o',
needed by
`/home/ignacio/work/software/source/rr231x_0x-linux-src-v2.0/product/rr2310pm/linux/.build/os_linux.o'.
 Stop.
make[1]: ***
[_module_/home/ignacio/work/software/source/rr231x_0x-linux-src-v2.0/product/rr2310pm/linux/.build]
Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.22.1-41.fc7-i686'
make: *** [rr2310_00.ko] Error 2


What's odd is that Makefile.def (which the main Makefile includes) has the
following rule:

%.o: %.c $(SHARED_HEADERS)
        @echo $(if $V,,[CC] $<)
        $(if $V,,@)$(CROSS_COMPILE)$(CC) $(CFLAGS) -c -o $@ $<

and os_linux.c is in osm/linux.
Comment 4 Petr Machata 2007-10-08 14:10:00 EDT
Is this still a problem with latest kernel?  Because it pretty much looks like a
problem in kernel build machinery, rather than make, and one that was already
fixed, because I can't reproduce this.
Comment 5 Bug Zapper 2008-05-14 09:49:34 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2008-06-16 22:04:08 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.