Bug 25060 - [patch] rp3 segfaults on startup
[patch] rp3 segfaults on startup
Product: Red Hat Linux
Classification: Retired
Component: rp3 (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Aaron Brown
Florence RC-1
Depends On:
  Show dependency treegraph
Reported: 2001-01-26 18:23 EST by Eido Inoue
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-02-07 08:51:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
gdb stackdump (663 bytes, text/plain)
2001-01-26 18:27 EST, Eido Inoue
no flags Details
rp3-null.patch (863 bytes, patch)
2001-02-07 08:47 EST, Tim Waugh
no flags Details | Diff

  None (edit)
Description Eido Inoue 2001-01-26 18:23:22 EST
launching as root seems ok.
Comment 1 Eido Inoue 2001-01-26 18:28:00 EST
Created attachment 8348 [details]
gdb stackdump
Comment 2 Nalin Dahyabhai 2001-01-29 16:00:21 EST
Are all of the ifcfg-XXX files in /etc/sysconfig/network-scripts world-readable?
Comment 3 Glen Foster 2001-01-29 19:01:25 EST
This defect is considered MUST-FIX for Florence Release-Candidate #1
Comment 4 Chris Evans 2001-02-06 12:31:42 EST
Blew up on me too.
Used the desktop icon to configure my dialup account.
Ran up rp3 and BANG.
This is very nasty. Possibly the most severe bug I've found in beta3.
Comment 5 Tim Waugh 2001-02-07 08:46:45 EST
It's caused by
(a) not enough error checking in rp3
(b) /etc/sysconfig/network-scripts/ifcfg-eth0 not being world readable

Here's a fix for (a).
Comment 6 Tim Waugh 2001-02-07 08:47:14 EST
Created attachment 9220 [details]
Comment 7 Nalin Dahyabhai 2001-02-12 21:17:59 EST
Should work again in rp3-1.1.7, which hit the tree today.

Note You need to log in before you can comment on or make changes to this bug.