Bug 25060 - [patch] rp3 segfaults on startup
Summary: [patch] rp3 segfaults on startup
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rp3   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Aaron Brown
URL:
Whiteboard: Florence RC-1
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-26 23:23 UTC by Eido Inoue
Modified: 2005-10-31 22:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-07 13:51:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gdb stackdump (663 bytes, text/plain)
2001-01-26 23:27 UTC, Eido Inoue
no flags Details
rp3-null.patch (863 bytes, patch)
2001-02-07 13:47 UTC, Tim Waugh
no flags Details | Diff

Description Eido Inoue 2001-01-26 23:23:22 UTC
launching as root seems ok.

Comment 1 Eido Inoue 2001-01-26 23:28:00 UTC
Created attachment 8348 [details]
gdb stackdump

Comment 2 Nalin Dahyabhai 2001-01-29 21:00:21 UTC
Are all of the ifcfg-XXX files in /etc/sysconfig/network-scripts world-readable?

Comment 3 Glen Foster 2001-01-30 00:01:25 UTC
This defect is considered MUST-FIX for Florence Release-Candidate #1

Comment 4 Chris Evans 2001-02-06 17:31:42 UTC
Blew up on me too.
Used the desktop icon to configure my dialup account.
Ran up rp3 and BANG.
This is very nasty. Possibly the most severe bug I've found in beta3.

Comment 5 Tim Waugh 2001-02-07 13:46:45 UTC
It's caused by
(a) not enough error checking in rp3
(b) /etc/sysconfig/network-scripts/ifcfg-eth0 not being world readable

Here's a fix for (a).

Comment 6 Tim Waugh 2001-02-07 13:47:14 UTC
Created attachment 9220 [details]
rp3-null.patch

Comment 7 Nalin Dahyabhai 2001-02-13 02:17:59 UTC
Should work again in rp3-1.1.7, which hit the tree today.


Note You need to log in before you can comment on or make changes to this bug.