Bug 250621 - Stellarium crashes with LANG set to is_IS.UTF-8
Stellarium crashes with LANG set to is_IS.UTF-8
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: stellarium (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Jochen Schmitt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-02 10:34 EDT by Johannes Reykdal
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.8.2-6.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-13 13:07:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace output (984.24 KB, text/plain)
2007-08-02 16:44 EDT, Johannes Reykdal
no flags Details
Patch to solve the weekday issue (555 bytes, text/plain)
2007-08-07 14:10 EDT, Jochen Schmitt
no flags Details

  None (edit)
Description Johannes Reykdal 2007-08-02 10:34:42 EDT
Description of problem:
Stellarium segfaults if LANG variable is set to is_IS.UTF-8. Does not segfault
if set to us_US.

Version-Release number of selected component (if applicable):
stellarium-0.8.2-5.fc7

How reproducible:
Always

Steps to Reproduce:
1. Run stellarium
2. Watch it crash.

  
Actual results:
Segmentation fault

Expected results:
Working program

Additional info:
[jreykdal@az03081 ~]$ stellarium
 -------------------------------------------------------
[ This is Stellarium 0.8.2 - http://www.stellarium.org ]
[ Copyright (C) 2000-2006 Fabien Chereau et al         ]
 -------------------------------------------------------
Application locale is en_US
Localizing TUI for locale: en_US
Loading Solar System data...(loaded)
Loading location: "Reykjavik", on Earth (landscape is: "guereins")
Loading Hipparcos star data...(118217 stars loaded [2200 dropped]).
Loading Hipparcos double stars...(8824 stars loaded)
Loading Hipparcos periodic variable stars...(1930 stars loaded)
Load star names from /usr/share/stellarium/data/sky_cultures/western/star_names.fab
Loading NGC data... (13226 items loaded [3175 dropped])

...no position data for Barnard's galaxy
...no position data for Papillon
...no position data for γ Cas nebulaLoading NGC name data...( 225 names loaded)
Loading Nebula Textures...(75 textures loaded)
Loading Constellation boundary data from
/usr/share/stellarium/data/constellations_boundaries.dat ...
(782 segments loaded)
Load star names from /usr/share/stellarium/data/sky_cultures/western/star_names.fab
Loading Cities data...(2069 cities loaded)
Localizing TUI for locale: en_US
Script completed.
Segmentation fault
Comment 1 Jochen Schmitt 2007-08-02 14:15:32 EDT
I could reproduced your bug with stellarium-0.8.2. But when I install
stellarium-0.9.0-2 from rawhide the issue doesn't occur.

So you may be helpful, if you can installed stellarium-0.9.0-2 from rawhide and
check the occurrence of your reported issue.

Comment 2 Johannes Reykdal 2007-08-02 16:44:07 EDT
Created attachment 160547 [details]
strace output
Comment 3 Johannes Reykdal 2007-08-02 17:25:13 EDT
(In reply to comment #1)
> I could reproduced your bug with stellarium-0.8.2. But when I install
> stellarium-0.9.0-2 from rawhide the issue doesn't occur.
> 
> So you may be helpful, if you can installed stellarium-0.9.0-2 from rawhide and
> check the occurrence of your reported issue.
> 
> 

that was not working too well for me.

I tried using strace and noticed that it crashed while looking at /etc/localtime
stat64("/etc/localtime", {st_mode=S_IFREG|0644, st_size=1141, ...}) = 0
stat64("/etc/localtime", {st_mode=S_IFREG|0644, st_size=1141, ...}) = 0
stat64("/etc/localtime", {st_mode=S_IFREG|0644, st_size=1141, ...}) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

I then tried to losen the restrictions on that file and then it works...once.
That really bugs me. It works sometimes but not always.
Comment 4 Jochen Schmitt 2007-08-05 14:30:17 EDT
You may be helpful, if you are able to create a backtrace. I have tried it, but
I was not able to get control on gdb after stellarium was started.
Comment 5 Jochen Schmitt 2007-08-06 13:18:26 EDT
I was able to create a backtrace.

Perhaps someone have an idea what is going wrong here

#0  0x0000003a3ee77160 in strlen () from /lib64/libc.so.6
#1  0x0000003a3ee8feb7 in strftime_l () from /lib64/libc.so.6
#2  0x0000003a3ee8f38b in strftime_l () from /lib64/libc.so.6
#3  0x000000000052cd1b in StelApp::get_printable_date_local (this=0x9532c0,
JD=2454319.1536689815) at stel_utility.h:45
#4  0x0000000000496a23 in StelUI::updateTopBar (this=0x96e1f0) at stel_ui.cpp:284
#5  0x0000000000497bb0 in StelUI::gui_update_widgets (this=0xae00000121,
delta_time=297991280) at stel_ui.cpp:1307
#6  0x000000000052ba53 in StelApp::update (this=0x9532c0, delta_time=<value
optimized out>) at stelapp.cpp:253
#7  0x0000000000444403 in StelApp::start_main_loop (this=0x9532c0) at
stel_sdl.cpp:483
#8  0x0000000000443258 in main (argc=<value optimized out>, argv=0x7fff11c30578)
at stelapp.h:86
#9  0x0000003a3ee1dab4 in __libc_start_main () from /lib64/libc.so.6
#10 0x0000000000409509 in _start ()
Comment 6 Johannes Reykdal 2007-08-06 13:56:37 EDT
Got some hints.

If I change "flag_show_date" in config.ini to "false" then everything works fine.

The date in is_IS would be displayed as Ágú 06 (with accented characters) so
that might be what crashes the program.

Comment 7 Jochen Schmitt 2007-08-07 14:10:18 EDT
Created attachment 160833 [details]
Patch to solve the weekday issue

Patch to solve the weekday displaying issue.
Comment 8 Jochen Schmitt 2007-08-07 14:10:44 EDT
I have found the reason for the issue. stellarim create a struct tm from scratch
without setting the weekday. If you have a locale where the weekday will be
displayed, you will got a segfault.

I have create a patch, which should solve the issue. It will be nice, if you can
do a test.
Comment 9 Johannes Reykdal 2007-08-07 16:49:51 EDT
Nice job...seems to work.

Thank you very much.
Comment 10 Fedora Update System 2007-08-09 12:49:04 EDT
stellarium-0.8.2-6.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Johannes Reykdal 2007-08-10 13:37:47 EDT
stellarium-0.8.2-6.fc7.i386.rpm works great.
Comment 12 Fedora Update System 2007-08-13 13:07:42 EDT
stellarium-0.8.2-6.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.