Bug 250635 - GNOME not honoring width in modeline setting in xorg.conf
GNOME not honoring width in modeline setting in xorg.conf
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-nv (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
desktop-bugs@redhat.com
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-02 12:26 EDT by Thomas Cameron
Modified: 2013-11-05 14:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-05 14:35:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
sysreport of the affected system. (523.57 KB, application/x-bzip)
2007-08-02 12:26 EDT, Thomas Cameron
no flags Details
Xorg.0.log from the sysreport (53.99 KB, text/plain)
2007-09-07 12:35 EDT, Matěj Cepl
no flags Details
xorg.conf from the sysreport (2.50 KB, text/plain)
2007-09-07 12:36 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Thomas Cameron 2007-08-02 12:26:44 EDT
Description of problem:
When using system-config-display, I get a bad width setting and my display is
"squished" to the right on my flatscreen.  Using xvidtune I reduce the width
from 1904 to 1828 and it displays just fine.  I used the -show argument to
xvidtune to get the modeline setting which causes my flatscreen to look right,
and I added that to the Monitor section of my xorg.conf file.  However, when I
leave X and come back in, the width setting is back at 1904, ignoring the
setting in xorg.conf:

[root@beast ~]# grep modeline /etc/X11/xorg.conf 
        modeline "1440x900"    106.50   1440 1520 1672 1828    900  903  909 934
+hsync -vsync

[root@beast ~]# xvidtune -show
"1440x900"    106.50   1440 1520 1672 1904    900  903  909  934 +hsync -vsync

You can see that the width is set to 1828 in xorg.conf, but it is not being honored.

Version-Release number of selected component (if applicable):
xorg-x11-drv-nv-1.2.0-4.fc6

How reproducible:
Add a modeline section to the Monitor section of xorg.conf.

Steps to Reproduce:
See above
  
Actual results:
The width setting is not honored.

Expected results:
Width section should be honored.

Additional info:
This is an x86_64 Red Hat Enterprise Linux Client release 5 (Tikanga) system
which is up to date as of today (August 2nd).  It is a dual core Athlon 64 4600+
with 4GB memory and a plain old IDE drive.  The motherboard is an ASUS KN8-SLI
board.  The video card is an nVidia Corporation GeForce 7300 GS (rev a1) card.
Comment 1 Thomas Cameron 2007-08-02 12:26:48 EDT
Created attachment 160534 [details]
sysreport of the affected system.
Comment 2 Allen Kistler 2007-08-05 13:53:33 EDT
I also see the same bug, but with different hardware (though still nv), modes,
etc. (RHEL5 Workstation)

A better description might be "xorg ignores Modeline in xorg.conf," since it's
all the values, not just the width parameter, that's ignored.

I can't tell if it's specific to nv, since I have no non-nv hardware on which to
test.

tc: Should the priority be bumped from low to medium?  This bug seems like
pretty basic functionality that should be fixed.
Comment 3 Allen Kistler 2007-08-18 02:00:07 EDT
I've got the modeline not to be ignored by changing the Mode name in xorg.conf
to be something other than one of the default names.

Instead of
Section "Monitor"
        Identifier   "Monitor0"
        Modeline     "1024x768" 78.80 1024 1056 1152 1312 ...
I use
Section "Monitor"
        Identifier   "Monitor0"
        Modeline     "Override" 78.80 1024 1056 1152 1312 ...

Then setting ...

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        SubSection "Display"
                Modes     "Override"

... works for me.
Comment 4 Matěj Cepl 2007-09-07 12:35:48 EDT
Created attachment 190151 [details]
Xorg.0.log from the sysreport
Comment 5 Matěj Cepl 2007-09-07 12:36:12 EDT
Created attachment 190161 [details]
xorg.conf from the sysreport
Comment 6 Adam Jackson 2007-12-18 19:03:59 EST
Thomas, how did you get that modeline into your xorg.conf in the first place?
Comment 7 Thomas Cameron 2007-12-19 13:29:58 EST
vim.  The Viewsonic LCD monitors I use are "optimized" for 1440x900 and they pop
up annoying little messages about needing to be at 1440x900 for best results, so
I set up that resolution and then used xvidtune to move the screens until they
looked right.  I hit the "show" button in xvidtune to display the modeline and
then edited the xorg.conf file.
Comment 8 Adam Jackson 2013-11-05 14:35:05 EST
No further X updates are planned for RHEL5.

Note You need to log in before you can comment on or make changes to this bug.