Bug 250639 - U.S. International Keyboard table missing Ç and ç
U.S. International Keyboard table missing Ç and ç
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity urgent
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
FF3RawhideClose
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-02 13:01 EDT by marcelo_carvalh
Modified: 2009-03-02 13:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 11:47:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description marcelo_carvalh 2007-08-02 13:01:37 EDT
Description of problem:

Version-Release number of selected component (if applicable):

Fedora Core 7, installed with Live CD + updates.

How reproducible:
Always.

Steps to Reproduce:
1. Go to: SYSTEM->ADMINISTRATION->KEYBOARD

2. Select Language = English; Select Keyboard to U.S.INTERNATIONAL (All U.S.A.
keyboards work with this option).

3. Test "TILDA" Combination: Type single quote character on the keyboard
followed by the character "C" using LOWER and HIGH cases:
 
Actual results:
  Ć  and  ć 

Expected results:
  Ç   and   ç

Additional info:
Impact: Impossible to write in Portuguese text (or any other languages) that   
uses "Ç" and "ç", and there is no such character on the international table;
This turns impossible the use of fedora to write Portuguese text in USA (which I
just tried for the first time). Sad, I had to go back to Microsoft..
Comment 1 marcelo_carvalh 2007-08-02 14:42:11 EDT
Additional: The character table on Firefox Browser display correct; but values 
sent to e-mail are invalid as follows:

Actual results:   Ć  and  ć 
Expected results:   Ç   and   ç

As shown in yahoo mail.

Actual results:  Ć  and  ć 
Expected results: Ç   and   ç

Comment 2 Ivana Varekova 2007-08-06 04:32:47 EDT
Hello,
to create Ç or ç it is necessary to press AltGr-< (AltGr-Shift-<) (see Keyboard
layout pages for US-International keyboard) - so there is no problem with
terminal output. 
There remains the problem you described in comment #1 -> I'm reasigning this bug
to firefox component. 
Comment 3 Christopher Aillon 2007-08-07 13:43:01 EDT
The email problem is likely due to an incorrect Charset header in the email. 
What is the value of this header?
Comment 4 marcelo_carvalh 2007-08-08 12:54:14 EDT
2 Comments:

1) Current e-mails settings: default

Characters text/plain; charset=utf-8 are corrupted, some characters
are misinterpreted.

In other words, the same e-mail that can be opened using IE on Windows,  
without errors, is shown wrong inf Fedora-Firefox. But Firefox works fine on
Windows, opens e-mails with no errors.

US settings are perfect without special adjustments to receive most of the
Brazilian-Portuguese text files (also Portugal), except  for some "Brazilian
Specific Keyboard" keys, which I never used because I don like them.


2) U.S. International Keyboard is standard. It supports US and "Part of the
rest of the World", without big changes.

AltGr-< (AltGr-Shift-<) IS NOT the correct sequence for U.S. International
layout, at least not for my past 10 years using notebooks, laptops, desktops
running from Windows 3.11, Windows 95, Windows 98, Windows 2000, Windows NT,
Windows XP and VISTA.

The idea of changing standard sequence to write Brazilian-Portuguese characters
is not good. At least not if you think of a country that was once bigger than
USA (until USA acquired Alaska Brazil was geographically speaking Brazil was
bigger in territory than US), with little less than the US population. Millions
of people are surely not willing to change the way they use their keyboards to
"adjust" to a new Fedora scheme. This problem is bigger than it seams to be.
Comment 5 Matěj Cepl 2007-12-20 11:47:01 EST
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays
Comment 6 Douglas Caixeta 2009-02-24 18:22:24 EST
Well I use Firefox 3 and this bug is present.

When I go to System > Hardware > Keyboard I have the proper setup for the keyboard.
I use the field to test and everything is OK.

When I go outside, anywhere (firefox or gedit) I cannot make 'ç'. Is always 'ć'.

Some foruns told me to go system-config-keyboard and change the default keyboard for all the users. But still I got the same problem.
Comment 7 Daniel Conceição 2009-03-02 13:12:59 EST
This is not (only) a Firefox issue.

I use Fedora 10, with language pt_BR.UTF-8, keyboard layout us-international, in a HP DV6448 Notebook, and have this bug happening to me in OpenOffice, Quanta Plus, Terminal, Anjuta, just to name a few.

I just upgraded from Fedora 9, and it wasn't happening then.

The funny thing is, the test field for keyboard layout in System Settings -> Preferences -> Hardware -> Keyboard, show the correct character "ç", in any other text input field appears the invalid character "ć".

So if it is needed any other info, please contatc me, I would love to help.

Cheers and keep up with the good work.

Note You need to log in before you can comment on or make changes to this bug.