Bug 250641 - RFE: update to 4.0 release
Summary: RFE: update to 4.0 release
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: shorewall (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Robert Marcano
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 321731
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-02 17:06 UTC by Jonathan Underwood
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 4.0.5-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-20 18:10:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Underwood 2007-08-02 17:06:27 UTC
Description of problem:
Upstream has released a new stable version - version 4. This is packaged
differently, now being split into 3 tarballs: shorewall-common.tar.gz,
shorewall-perl.tar.gz and shorewall-shell.tar.gz. the -shell and -perl packages
are two different compilers. I'd suggest packaging them as three different RPMs,
and having a shoreall metapackage which pulls in shorewall-common and
shorewall-perl.

Comment 1 Jonathan Underwood 2007-10-07 01:07:41 UTC
Version 4 packages submitted for review - see BZ #321731

Comment 2 Robert Marcano 2007-10-07 04:51:10 UTC
I welcome  your help on this, I have been only doing security updates to shorewall recently and I had no plans to update it to 4.0 in a near term. Just a question, why create so many source packages instead of only one (the current one) with  all the tarballs and many subpackages. It looks like all tarballs are released each time with every update so they do not look too independent between them, and having them separated with just only give you problems with the new update system that does not publish everything  inmediatly, so you will need to update for example shorewall-common, publish it to testing, request it to be added to the build repository (testing is not included by default) and then build shorewall-perl, with every update

Comment 3 Robert Marcano 2007-10-07 04:54:54 UTC
ohh ugly formatted line, bugzilla needs to be able to auto limit long lines

Comment 4 Jonathan Underwood 2007-10-07 11:55:50 UTC
Hi Robert,

In reply to Comment #2: the reason is that there's a requirement to have one
tarball per package in Fedora. In this there is no build time interdependence
between the packages, so there is not the problem you point too.

[OTOH, I do agree from a maintainence perspective it would be simpler to have
one big package with 3 tarballs.]

I think I'll ask on fedora-devel how strict the one tarball per package rule
actually is.

Comment 5 Jonathan Underwood 2007-10-07 12:27:20 UTC
Having discussed this on #fedora-devel, there seems to be a strong agreement
with the one package with all the tarballs in approach. That's a bit of a relief
actually, as it will make life much easier. I'll hack all of them together and
post a new spec and SRPM shortly.

Comment 6 Jonathan Underwood 2007-10-08 00:03:27 UTC
I have made a one-package many-tarball approach package now - see BZ #321731. On
balance, I think this is the way to go.

Comment 7 Fedora Update System 2007-11-15 03:34:39 UTC
shorewall-4.0.5-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update shorewall'

Comment 8 Fedora Update System 2007-11-20 18:10:20 UTC
shorewall-4.0.5-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.