Bug 250676 - Need to move the powered_by_fedora.png from lighttpd to fedora-logos
Need to move the powered_by_fedora.png from lighttpd to fedora-logos
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fedora-logos (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 250674
  Show dependency treegraph
 
Reported: 2007-08-02 16:31 EDT by Jef Spaleta
Modified: 2013-03-05 22:51 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-22 10:28:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2007-08-02 16:31:39 EDT
Getting all our eggs in one basket to make legal happy and to make it easier for
people to use revisor/wevisor without running afoul with our branding rules.


-jef
Comment 1 Matthias Saou 2007-08-06 06:43:24 EDT
CC'ing Joe Orton, since httpd also contains
"/var/www/icons/powered_by_fedora.png" which is basically the same file. Maybe
we can have a single "powered_by.png" image in a non-Fedora specific path to
which all web server packages can include a dangling symlink to, and require
"system-logos"?

Because if we have /usr/share/pixmaps/fedora/powered_by_fedora.png", people
making respins of Fedora will still need to modify httpd/lighttpd/boa/etc. to
change the included symlink in order to remove "fedora" from the path and file name.

Once we have the button in fedora-logos, in the most abstract possible way (no
"fedora" in the file path or name), I'll update lighttpd, boa and thttpd to
point to that.
Comment 2 Joe Orton 2007-08-06 06:49:24 EDT
Ah yes, Jesse requested this before too for httpd.  The "welcome page"
(http://localhost/) also contains Fedora branding.  What does lighttpd etc do
for the same case?
Comment 3 Matthias Saou 2007-08-06 07:05:39 EDT
(In reply to comment #2)
> Ah yes, Jesse requested this before too for httpd.  The "welcome page"
> (http://localhost/) also contains Fedora branding.  What does lighttpd etc do
> for the same case?

Currently, lighttpd, thttpd and boa all contain a copy of the
"powered_by_fedora.png" button, just like httpd. But the default setup of all
three should allow a symlink to a system-wide "powered_by.png" button to work
(I'm not 100% sure if the default selinux policy would, though).
Comment 4 Jef Spaleta 2007-08-06 12:15:38 EDT
(In reply to comment #1)
> Because if we have /usr/share/pixmaps/fedora/powered_by_fedora.png", people
> making respins of Fedora will still need to modify httpd/lighttpd/boa/etc. to
> change the included symlink in order to remove "fedora" from the path and file
name.
> 
> Once we have the button in fedora-logos, in the most abstract possible way (no
> "fedora" in the file path or name), I'll update lighttpd, boa and thttpd to
> point to that.

Yes this is sort of the general plan.
http://fedoraproject.org/wiki/Releases/FeatureGenericLogos

-jef
Comment 5 Matthias Saou 2007-08-19 14:46:41 EDT
What's the current status? If we want this done for Fedora 8, then we should
hurry. I'd like to see the 88x31 PNG button included in fedora-logos, but under
a path/name which is generic enough to be hardcoded into the web server default
html pages. Something like :
/usr/share/pixmaps/www/powered_by.png

Or anything else that doesn't contain "fedora" in the path or file name, but
that will always be a nice little button with "Powered by Fedora" in the latest
artwork fashion ;-)

Who needs to give the green light on this? Do we need more thoughts on where to
store this type of artwork?
Comment 6 Matthias Saou 2007-09-12 07:14:32 EDT
Ping? I just need a long-term working path for the button image...
Comment 7 Bill Nottingham 2007-09-13 13:19:30 EDT
The problem is, at least with some servers, they won't follow symlinks out of
the docroot. So we'd need triggers, or sometihng.

Still investigating.
Comment 8 Joe Orton 2007-09-13 14:24:24 EDT
So as I've been over (somewhere) before, there are two parts to this which have
Fedora branding:

1) the powered_by.png logo
2) the default http://localhost/ page

these would both need moving somewhere common, and:

a) aliases set up in welcome.conf or something, and 
b) SELinux policy tweaked, and
c) httpd packaging tweaked

After all that work, people who rebrand Fedora will still build custom httpd
packages, since they want a custom Server version header for marketing purposes.  

End result - it means lots of work for us, and makes little difference to
rebranders.  So why bother?
Comment 9 Bill Nottingham 2007-09-13 14:48:33 EDT
There are the trademark guidelines to follow. The simplest thing would be to
just *not have the branding in the web page*. We can always just put the button
in fedora-logos somewhere for people to use if they want.
Comment 10 Bill Nottingham 2007-09-13 17:11:07 EDT
Added in 7.92.1-1.fc8 as /usr/share/pixmaps/poweredby.png. Suggest, in order of
preferences:

1) web servers nuke the branding from the test pages
2) web server packages symlink, if they can take it
3) web server packages use triggers to copy it in
Comment 11 Joe Orton 2007-09-14 04:50:16 EDT
What exactly do the trademark guidelines require w.r.t. packaging?  Can we leave
the word "Fedora" in the server version string?
Comment 12 Joe Orton 2007-09-14 04:51:39 EDT
(that is, the Server: response header)
Comment 13 Matthias Saou 2007-09-14 05:04:01 EDT
I don't really care what we do, as long as it's consistent across all the web
server packages we provide. Currently my choices would be :
1) Nuke the branding from the default web page altogether.
2) Copy the poweredby.png in post and a trigger, and have it ghost/noverify.

For end users, 2) is prettier, then again if there is a nice enough design and
some branding of the upstream project, it might make little difference (which
reminds me that I'll need to confirm permission to use those logos and
trademarks to the upstream projects). But will 2) cope with selinux without
being ugly?
Comment 14 Bill Nottingham 2007-09-14 09:33:32 EDT
(In reply to comment #11)
> What exactly do the trademark guidelines require w.r.t. packaging?  Can we leave
> the word "Fedora" in the server version string?

Sure. It's the trademarked image that's problematic.
Comment 15 Joe Orton 2007-09-17 03:56:45 EDT
What am I supposed to Require from httpd then?  The Feature page doesn't
actually say.  I presumed generic-logos, but that doesn't exist yet. 
system-logos?  fedora-logos? Require-by-file?
Comment 16 Joe Orton 2007-09-17 04:05:20 EDT
Also: are we required by trademark guidelines/any other motivation to remove the
branding from the default http://localhost/ page?  I'd prefer to not do that.
Comment 17 Bill Nottingham 2007-09-17 14:43:14 EDT
The requires should be on system-logos, which both fedora-logos and
generic-logos will provide.

As for other branding, it depends on the trademarks of the images used in that
branding - as long as Apache (or whatever) is fine with it, it's fine with us.
Comment 18 Joe Orton 2007-09-18 04:09:29 EDT
I was only really asking about the use of the word "Fedora" in the
http://localhost/ page.  I've left that page as-is, presuming that is OK.

httpd-2.2.6-3 now uses the poweredby.png from system-logos.
Comment 19 Matthias Saou 2007-10-22 10:28:16 EDT
lighttpd-1.4.18-2, thttpd-2.25b-15 and boa-0.94.14-0.9.rc21 all now use the
poweredby.png from system-logos.
Unless other web servers have been left out, this should be it, so I'm closing
the bug now. Thanks to all! :-)

Note You need to log in before you can comment on or make changes to this bug.