Bug 250683 - Keyboard frequently doesn't work when coming out of suspend
Keyboard frequently doesn't work when coming out of suspend
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-02 16:55 EDT by David Campbell
Modified: 2009-01-09 02:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:11:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sound that fedora plays when this keyboard problem happens (79.18 KB, audio/mpeg)
2007-08-02 16:55 EDT, David Campbell
no flags Details
lsmod, lspci, and dmesg text (85.51 KB, text/plain)
2007-09-25 18:18 EDT, David Campbell
no flags Details
dmesg without vmware loaded (36.50 KB, text/plain)
2007-09-26 09:15 EDT, David Campbell
no flags Details
workaround that seems to work when installed in /etc/pm/sleep.d (440 bytes, text/plain)
2007-11-28 15:49 EST, David Campbell
no flags Details
dmesg from pauljohn's computer (23.07 KB, text/plain)
2007-11-30 16:17 EST, Paul Johnson
no flags Details
lspci from pauljohn's computer (13.74 KB, text/plain)
2007-11-30 16:18 EST, Paul Johnson
no flags Details
lsmod from pauljohn's computer (2.48 KB, text/plain)
2007-11-30 16:18 EST, Paul Johnson
no flags Details

  None (edit)
Description David Campbell 2007-08-02 16:55:21 EDT
Description of problem:

I have a notebook computer with built-in keyboard and external keyboard
connected (PS2).

Very frequently, particularly when I've suspended one night and have turned the
computer on the next morning, neither keyboards work and I cannot enter my
password unless I unplug the external keyboard and plug it back in again, in
which case both keyboards are then working.

Note also that when this keyboard problem happens, fedora plays a sound which I
have recorded and attach.

Please refer to the attachments in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=250677 as both problems
happened in this instance, but note that if desktop effects is disabled, this
problem still happens.

Version-Release number of selected component (if applicable):

2.6.22.1-41.fc7 with all packages up to date, though this has been happening
since the original f7 release.  I wasn't a user of a previuos fedora release.

How reproducible:

Happens very frequently

Steps to Reproduce:
1. Suspend the computer
2. [perhaps wait overnight]
3. Turn on the computer out of suspend
4. Try keyboard
5. If problem, disconnect external keyboard and reconnect

Actual results:

Often keyboard doesn't work

Expected results:

Keyboard should always work
Comment 1 David Campbell 2007-08-02 16:55:22 EDT
Created attachment 160550 [details]
sound that fedora plays when this keyboard problem happens
Comment 2 Adam Jackson 2007-08-06 13:54:27 EDT
X doesn't do anything special with the keyboard for suspend.  If it doesn't work
coming back from suspend, that's probably the kernel's fault.
Comment 3 David Campbell 2007-08-31 00:53:25 EDT
This problem is really troublesome.... I have been finding that frequently even
if an external keyboard is plugged in when this problem shows, that the only
option for me is to shut down the computer using the mouse and restart it.  The
keyboard(s) are totally non-functional.
Comment 4 Christopher Brown 2007-09-23 16:14:40 EDT
Hello David,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel? If you are, please post
the output from the following commands as separate text/plain attachments:

# lsmod
# lspci -vvxxx
# dmesg

as well as the make and model of your machine.

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 5 David Campbell 2007-09-24 22:46:03 EDT
I'll get back to you with more detail as to whether this problem still happens
with the 2.6.22.5-76.fc7 kernel which I have just upgraded to in the last day or
so.  I usually shut my computer down to standby each night and that should
provide a good test for this.
Comment 6 David Campbell 2007-09-25 18:18:47 EDT
Created attachment 206191 [details]
lsmod, lspci, and dmesg text

Yes this problem still happens with the 2.6.22.5-76.fc7 kernel.

I attach detail as you request.
Comment 7 David Campbell 2007-09-25 18:30:52 EDT
My machine is a Clevo D870P.  Clevo systems are also sold as Kapok, FOSA,
Eurocom, and a myriad of other names.

I also recommend taking a look at my related separate case
https://bugzilla.redhat.com/show_bug.cgi?id=251080 which other people have also
experienced.
Comment 8 Alan Cox 2007-09-26 08:54:04 EDT
The dump isn't so useful as you've got vmware loaded and vmware does strange
things to machines sometimes. However it shows you getting irregular timeouts
until we hit PIO modes which is useful.

Comment 9 David Campbell 2007-09-26 09:15:55 EDT
Created attachment 207041 [details]
dmesg without vmware loaded

I've rebooted with the vmware modules not loaded now, and I'm attaching the
dmesg without it.  You can see there are some disk DMA related issues going on
and I've opened another case at
https://bugzilla.redhat.com/show_bug.cgi?id=250349 about it.
Comment 10 David Campbell 2007-10-02 07:21:39 EDT
Somebody else experiencing a similar problem pointed out that when this problem
happens you see this in the logs, note the "unknown error".  I see it too and I
failed to mention it:

Oct  2 08:01:09 localhost kernel: Stopping tasks ... done.
Oct  2 08:01:09 localhost kernel: Suspending console(s)
Oct  2 08:01:09 localhost hcid[2481]: HCI dev 0 down
Oct  2 08:01:09 localhost gnome-power-manager: (dcampbel) An unknown error
occured code='32' quark='g-exec-error-quark'
Oct  2 08:01:09 localhost hcid[2481]: Stopping security manager 0
Oct  2 08:01:09 localhost hcid[2481]: Device hci0 has been disabled
Comment 11 David Campbell 2007-10-02 07:34:15 EDT
By repeatedly suspending and resuming, I've since proven that this "unknown
error" in my previous post doesn't happen every time the problem in this case
happens, thus it seems to be a separate issue (that ubuntu people are also seeing).
Comment 12 David Campbell 2007-11-19 23:22:59 EST
I'm not seeing this on f8, though I am seeing some other keyboard weirdness
Comment 13 David Campbell 2007-11-26 14:48:05 EST
No, I am seeing this on f8.

Apparently this is a kernel issue associated with the i8042 driver, affecting
many distros.

I am trialling the fix by Jan Skowron found at:
https://bugs.launchpad.net/ubuntu/+source/linux-meta/+bug/66255

If it turns out successful, I will soon post a script workaround here to be
installed in /etc/pm/sleep.d
Comment 14 David Campbell 2007-11-28 15:49:46 EST
Created attachment 271771 [details]
workaround that seems to work when installed in /etc/pm/sleep.d

Attaching a workaround, which unbinds and rebinds the i8042 driver.  Installing
it in /etc/pm/sleep.d has fixed this matter thus far for suspend/resume, but
the keyboard still plays up in two other circumstances I've seen:

[1]  When flicking over to text mode with CTRL-ALT-F1
[2]  When logging out of the desktop, I end up with a login screen at which I
cannot type.

When these other situations happen, the only options then are to reboot or ssh
in from another computer and run this script manually passing resume as an
option, in which case the keyboard comes good.
Comment 15 Paul Johnson 2007-11-30 16:17:40 EST
Created attachment 274361 [details]
dmesg from pauljohn's computer
Comment 16 Paul Johnson 2007-11-30 16:18:14 EST
Created attachment 274371 [details]
lspci from pauljohn's computer
Comment 17 Paul Johnson 2007-11-30 16:18:53 EST
Created attachment 274381 [details]
lsmod from pauljohn's computer
Comment 18 Paul Johnson 2007-12-01 13:41:09 EST
Looks like I accidentally deleted my explanation of the problem I'm having.  On
Dell D820 laptop with F8, my keyboard does not work after suspend/resume and the
kernel 2.6.23.1-49.fc8.  I DO NOT have a similar problem with 2.6.23.1-42.fc8. 
I've restarted several times, and believe the suspend/resume worked every time
with 42 but never would the keyboard work with 49.   The dmesg, lspci, and lsmod
files are from the misbehaving 49.
Comment 19 Christopher Brown 2008-02-03 17:09:24 EST
Could I prod folks for an update on this - is it still happening with the latest
kernels? Paul - can you test the workaround mentioned?
Comment 20 David Campbell 2008-02-03 17:20:03 EST
This problem still happens with the latest kernel, sometimes when shutting down
to suspend and restarting, sometimes when you log out, you lose the keyboard. 
If you then log in remotely and run these commands, which force a rebind of the
i8042 driver, then the keyboard works again....

      echo -n "i8042" > /sys/bus/platform/drivers/i8042/unbind
      echo -n "i8042" > /sys/bus/platform/drivers/i8042/bind

This seems to be a wider kernel issue...ubuntu folks are seeing it too..

      https://bugs.launchpad.net/ubuntu/+source/acpi-support/+bug/23497
Comment 21 Christopher Brown 2008-02-03 17:55:40 EST
Okay, thanks David.

Do you fancy taking this upstream to the kernel.org bugzilla. You have an
account there already I think...?
Comment 22 Bug Zapper 2008-11-26 02:37:58 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 23 Jan Martinek 2008-12-11 22:27:09 EST
I confirm this bug which is still present in 2.6.28-0.113.rc7.git5.fc11.x86_64. After resuming the computer, keyboard does not respond unless disconnected and connected again. The trick mentioned above

echo -n "i8042" > /sys/bus/platform/drivers/i8042/unbind
echo -n "i8042" > /sys/bus/platform/drivers/i8042/bind

does not work for me.

A tried USB keyboard as well as PS2 keyboard (using a convertor) and in it is the same both cases. Reproducibility is 100%.
Comment 24 Bug Zapper 2009-01-09 02:11:33 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.