Bug 250700 - forcedeth.c 0.42-rh disables sideband management unit
forcedeth.c 0.42-rh disables sideband management unit
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.5
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Andy Gospodarek
Martin Jenner
:
Depends On:
Blocks: 253592
  Show dependency treegraph
 
Reported: 2007-08-02 20:18 EDT by Andy Isaacson
Modified: 2014-06-29 18:58 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 15:01:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Isaacson 2007-08-02 20:18:49 EDT
Description of problem:

The forcedeth.c version 0.42-rh which is included in 2.6.9-55.0.2 does not
support the "sideband management unit" feature which is used on some modern
platforms to provide network connectivity for the IPMI BMC.  The symptom is that
once the admin issues "ifconfig eth0 down" and/or "rmmod forcedeth", the IPMI
BMC loses access to the network.

The forcedeth.c "0.62-Driver Package V1.23" available at
http://www.nvidia.com/object/linux_nforce_1.23.html does support the sideband
management unit, as well as providing support for a bunch of new hardware.

Version-Release number of selected component (if applicable):

kernel 2.6.9-55.0.2
forcedeth.c "0.42-rh"

How reproducible:
always

Steps to Reproduce:
1. install RHEL4u5 on Opteron with MCP55 chipset and IPMI-on-eth0 hardware
config, such as Penguin Computing Altus 600.
2. configure IPMI for network accessibility.
3. issue "ifconfig eth0 down; rmmod forcedeth" as root.
  
Actual results:
attempts to remotely reboot server using "ipmitool -H 10.0.0.2 chassis power
reset" will fail, stating inability to contact BMC.

Expected results:
remote reset with "ipmitool -H" should work no matter the state of the target OS.

Additional info:
Comment 1 Andy Gospodarek 2007-08-15 21:42:11 EDT
The next RHEL4 update will include a later version of the forcedeth driver
(0.60).  Test kernels that contain a patch for this (and a few other test
patches) are available here:

http://people.redhat.com/agospoda/#rhel4

Feel free to test these kernels and let us know if they resolve your issue.  Thanks!
Comment 2 Andy Isaacson 2007-08-16 19:25:58 EDT
Adding Ayaz Abdulla to cc list.
Comment 3 Andy Isaacson 2007-08-16 20:28:17 EDT
restoring needinfo, hadn't meant to remove that.  Will try to test soon.
Comment 4 Andy Isaacson 2007-08-17 19:08:04 EDT
I've verified that 2.6.9-55.21.EL.gtest.26.1 with forcedeth 0.60 fixes the IPMI
sideband issue, and it also addresses a locking bug that had been problematic
for us with nvidia's 0.60 and 0.62.

It appears that you'll want to merge 3ba4d093fe8a26f5f2da94411bf8732fa6e9da86
from upstream as well.

Note that 0.62 "Driver Package 1.23" is now available from nvidia.com.

Thanks for the great work!  This driver looks much better now.
Comment 5 Andy Gospodarek 2007-08-20 09:48:56 EDT
Glad to hear that is working for you, Andy!  

The last commit I pulled into this update was actually:

commit 6fedae1f6e66ab5f169bf58064e23e015fc1307d
Author: Ayaz Abdulla <aabdulla@nvidia.com>
Date:   Tue Feb 20 03:34:44 2007 -0500

So I pulled before the one you recommended.

commit 3ba4d093fe8a26f5f2da94411bf8732fa6e9da86
Author: Ayaz Abdulla <aabdulla@nvidia.com>
Date:   Fri Mar 23 05:50:02 2007 -0500

It probably won't make the upcoming update (4.6), but I'll pull together some of
the latest upstream fixes for my test kernels and hopefully push them into 4.7.

If it's OK with you I'd like to close out this bug since your main IPMI issue
seems to be resolved.  Seem reasonable?
Comment 6 Andy Isaacson 2007-08-20 14:10:32 EDT
(In reply to comment #5)
> If it's OK with you I'd like to close out this bug since your main IPMI issue
> seems to be resolved.  Seem reasonable?

Sounds good to me, but I'd like to make sure 3ba4d09 doesn't fall through the
cracks (I'll be maintaining it locally until it shows up in RHEL4.7 or
whatever).  Would you like to open a new ticket or shall I?
Comment 7 Andy Gospodarek 2007-08-20 15:01:01 EDT
Closing since the IPMI issue is resolved.  

Opened bug 253592 to deal with new patch request.

Note You need to log in before you can comment on or make changes to this bug.