Bug 250734 - Please put libILUT in its own subpackage
Please put libILUT in its own subpackage
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: DevIL (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ian Chapman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-03 06:10 EDT by Hans de Goede
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 1.6.8-0.12.rc2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-09 12:50:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans de Goede 2007-08-03 06:10:42 EDT
Hi Ian,

Today I got a couple of broken deps reports for packages in rawhide because of a
boost update, so I downloaded boost from koji (as rawhide is frozen for test1),
and tried to install it. However arts requires the old boost, so I tried to
remove arts.

This however not only resulted in the removal of KDE stuff, but also in the
removal of allegro (which should be split too, to avoid this) and through
allegro in the removal of DevIL, and through devel in the removal of ogre, but
ogre doesn;t use allegro in anyway!

The problem is that libILUT brings in many (sometimes unwanted) deps including
allegro:
[hans@shalem devel]$ ldd /usr/lib64/libILUT.so
        linux-vdso.so.1 =>  (0x00007fff5e5fd000)
        libIL.so.1 => /usr/lib64/libIL.so.1 (0x00002aaaaacdd000)
        libILU.so.1 => /usr/lib64/libILU.so.1 (0x00002aaaaaff2000)
        liballeg.so.4.2 => /usr/lib64/liballeg.so.4.2 (0x00002aaaab20e000)
        libGLU.so.1 => /usr/lib64/libGLU.so.1 (0x00002aaaab560000)
        libc.so.6 => /lib64/libc.so.6 (0x00002aaaab7cd000)
        libpng12.so.0 => /usr/lib64/libpng12.so.0 (0x00002aaaabb1f000)
        libjpeg.so.62 => /usr/lib64/libjpeg.so.62 (0x00002aaaabd43000)
        libtiff.so.3 => /usr/lib64/libtiff.so.3 (0x00002aaaabf64000)
        libmng.so.1 => /usr/lib64/libmng.so.1 (0x00002aaaac1be000)
        liblcms.so.1 => /usr/lib64/liblcms.so.1 (0x00002aaaac42c000)
        libz.so.1 => /lib64/libz.so.1 (0x00002aaaac660000)
        libm.so.6 => /lib64/libm.so.6 (0x00002aaaac875000)
        libXxf86vm.so.1 => /usr/lib64/libXxf86vm.so.1 (0x00002aaaacaf8000)
        libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x00002aaaaccfd000)
        libXpm.so.4 => /usr/lib64/libXpm.so.4 (0x00002aaaacf08000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00002aaaad119000)
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00002aaaad32a000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00002aaaad636000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00002aaaad850000)
        libGL.so.1 => /usr/lib64/libGL.so.1 (0x00002aaaada54000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00002aaaadcd2000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00002aaaadfd2000)
        /lib64/ld-linux-x86-64.so.2 (0x0000555555554000)
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00002aaaae1e1000)
        libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00002aaaae3ea000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00002aaaae5ef000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00002aaaae7f2000)
        libdrm.so.2 => /usr/lib64/libdrm.so.2 (0x00002aaaae9f7000)

Since there is no reason for people to get allegro installed for example when
they install an ogre based app, I believe that libILUT should be put in its own
subpackage (with its own -devel too).

I actually doubt we have any users of libILUT at all, so putting its in its own
subpackage will get rid of it when installing apps for many people I think.
Comment 1 Ian Chapman 2007-08-07 17:47:59 EDT
Hi Hans,

Here's the latest version which should hopefully do what you want. If you don't
mind giving it a quick sanity check and letting me know if it's ok (or not) then
I'll get it built. I've checked it by compiling cegui against it, minus the ILUT
parts so it seems to be good.

http://dribble.org.uk/reviews/DevIL.spec
http://dribble.org.uk/reviews/DevIL-1.6.8-0.12.rc2.src.rpm
Comment 2 Hans de Goede 2007-08-08 03:56:04 EDT
Thanks!

Looks good, I would add:
Requires:       %{name} = %{version}-%{release}

To the ILUT subpackage to make sure it uses the exact same %{version}-%{release}
of libIL.so.1 as its own version.
Comment 3 Ian Chapman 2007-08-08 13:12:06 EDT
(In reply to comment #2)

> Looks good, I would add:
> Requires:       %{name} = %{version}-%{release}

Good point! Done. 

The build is now in devel, earlier release will follow. Cheers Hans.
Comment 4 Fedora Update System 2007-08-09 12:50:47 EDT
DevIL-1.6.8-0.12.rc2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.