Bug 250736 - Spit of some plugins into a allegro-plugins-foo packages
Summary: Spit of some plugins into a allegro-plugins-foo packages
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: allegro   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-03 10:26 UTC by Hans de Goede
Modified: 2013-07-02 23:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-13 05:44:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2007-08-03 10:26:58 UTC
Today I got a couple of broken deps reports for packages in rawhide because of a
boost update, so I downloaded boost from koji (as rawhide is frozen for test1),
and tried to install it. However arts requires the old boost, so I tried to
remove arts.

This however not only resulted in the removal of KDE stuff, but also in the
removal of allegro (which should be split too, to avoid this) and through
allegro in the removal of many more packages.

I think that the dependency of allegro on arts is unwanted in most cases (people
should be able to install allegro without also getting arts + qt). The solution
would be to put:
/usr/lib64/allegro/4.2.2/alleg-artsdigi.so
In its own subpackage, the same argument could be made for the esound plugin (as
esound isn't used all that much anymore afaik) and we haven't even enabled the 
jack digi plugin, which we could/should also do provided we put it in its own
subpackge too.

Jindrich, this is just a reminder to myself, I will take care of this (once arts
is rebuild against the new boost).

Comment 1 Hans de Goede 2007-08-13 05:44:02 UTC
allegro-4.2.2-3.fc8, which fixes this, will be in the next rawhide push.



Note You need to log in before you can comment on or make changes to this bug.