Bug 250742 - Regression: New kernel introduces irq conflict between wireless and audio
Regression: New kernel introduces irq conflict between wireless and audio
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-03 08:52 EDT by Kaare Fiedler Christiansen
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.22.4-65.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-25 16:37:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Ouput of dmesg (24.21 KB, text/plain)
2007-08-03 08:52 EDT, Kaare Fiedler Christiansen
no flags Details
dmesg output from 2.6.22.1-33 kernel (21.59 KB, text/plain)
2007-08-03 09:04 EDT, Kaare Fiedler Christiansen
no flags Details

  None (edit)
Description Kaare Fiedler Christiansen 2007-08-03 08:52:33 EDT
Description of problem:

After upgrading to the 2.6.22.1-41 from 2.6.22.1-33 an IRQ conflict is
introduced, disabling both my wireless card and my audio card. The result is
especially bad for audio, since any program that attempts to emit audio freezes.

Version-Release number of selected component (if applicable):

2.6.22.1-41.fc7

How reproducible:

Always

Steps to Reproduce:
1. Boot machine
  
Actual results:

IRQ is disabled, see attached output of dmesg.

Expected results:

In 2.6.22.1-33.fc7 both wireless and audio worked
Comment 1 Kaare Fiedler Christiansen 2007-08-03 08:52:33 EDT
Created attachment 160602 [details]
Ouput of dmesg
Comment 2 Kaare Fiedler Christiansen 2007-08-03 09:04:09 EDT
Created attachment 160607 [details]
dmesg output from 2.6.22.1-33 kernel
Comment 3 John W. Linville 2007-08-03 09:51:39 EDT
Hmmm...did you try booting w/ the "irqpoll" kernel command line option?
Comment 4 Kaare Fiedler Christiansen 2007-08-03 12:01:09 EDT
I did, exactly same result (including the suggestion to try to boot with irqpoll...)
Comment 5 Kaare Fiedler Christiansen 2007-08-17 10:17:03 EDT
I just upgraded to the latest kernel in updates-testing, 2.6.22.2-57.fc7, and
that fixes the problem.

Will this kernel reach updates? In that case I consider the problem fixed.
Comment 6 Kaare Fiedler Christiansen 2007-08-25 16:37:19 EDT
Bug is fixed in new kernel from updates

2.6.22.4-65.fc7

Note You need to log in before you can comment on or make changes to this bug.