Bug 250743 - Permissions are wrong
Permissions are wrong
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: samba (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Simo Sorce
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-03 09:01 EDT by The Source
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 09:37:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
my smb config (10.81 KB, application/x-extension-conf)
2007-08-03 09:01 EDT, The Source
no flags Details
Samba logs (577 bytes, application/x-bzip)
2007-08-24 06:34 EDT, The Source
no flags Details

  None (edit)
Description The Source 2007-08-03 09:01:25 EDT
Description of problem:
I have the following samba configuration:
Users: thesource, Dmitry, smbguest
Guest account enabled: smbguest

Shares:
Disk_D - for everyone, read-only
Disk_C - for Dmitry, thesource - read-write
Disk_E - for Dmitry, thesource - read-write

So everyone has access to Disk_D as guest. But when someone tries to enter other
shares server should ask for password to change visitor's login to valid user
rather than smbguest but it allows access to those shares without any restrictions.


Version-Release number of selected component (if applicable):
samba-3.0.25b-2.fc7

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 The Source 2007-08-03 09:01:26 EDT
Created attachment 160605 [details]
my smb config
Comment 2 Simo Sorce 2007-08-23 15:08:55 EDT
Sorry I can't reproduce this problem with 3.0.25b, can you please rasie your log
level to 10 and provide a log file showing the problem ?
Comment 3 The Source 2007-08-23 16:21:28 EDT
Correction. Samba asks for password, but only when write operation attempt is
made. Reading is allowed to everyone. How to raise log level?
Comment 4 Simo Sorce 2007-08-23 16:54:58 EDT
set log level = 10
and also max log size = 0

also please report the output of the command /usr/sbin/smbd -V
Comment 5 The Source 2007-08-24 06:33:54 EDT
Strange. In latest tests server allowed to write to Disk_C without any questions
but denied writing to Disk_E to everyone.
Attaching logs.

Command output is "Version 3.0.25b-2.fc7"
Comment 6 The Source 2007-08-24 06:34:40 EDT
Created attachment 172402 [details]
Samba logs
Comment 7 Simo Sorce 2007-08-24 09:37:11 EDT
These logs are empty, in any case, I can't reproduce the problem, and I suspect
that you simply forgot to restert samba after changing the security features.
New security options are not applied until the client is disconnected and
reconnected to the server (a restart would force this).

Closing this one, please reopen if you can reproduce the problem after you
restart the server with the final configuration and please attach logs at level
10 in that case.

Note You need to log in before you can comment on or make changes to this bug.