Bug 250781 - RFE: update libgpod to 0.5.2
RFE: update libgpod to 0.5.2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libgpod (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Todd Zullinger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-03 12:00 EDT by Todd Zullinger
Modified: 2008-01-13 11:22 EST (History)
9 users (show)

See Also:
Fixed In Version: 0.6.0-3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-13 11:22:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libgpod-0.5.2 compatibility patch for quodlibet (647 bytes, patch)
2007-08-03 12:26 EDT, Todd Zullinger
no flags Details | Diff

  None (edit)
Description Todd Zullinger 2007-08-03 12:00:20 EDT
This is track the update of libgpod to 0.5.2 and (changes to | rebuilds of)
packages that depend on it.
Comment 1 Todd Zullinger 2007-08-03 12:26:36 EDT
Created attachment 160625 [details]
libgpod-0.5.2 compatibility patch for quodlibet

I think quodlibet is the only package that needs patched for the libgpod
update.  I sent a note upstream about this, but since I'm not subscribed the
the quodlibet list I'm not sure if it got through their moderation system.

There are 2 other details I noticed in testing quodlibet.

1) They store the bitrate * 1000, so tracks look to be encoded at 192000kbps in
gtkpod and other apps.	I think this is only a cosmetic annoyance, but I'm not
sure of that.  The tracks seemed to play fine on my iPod.

2) Rebuilding the package, desktop-file-install tossed some warnings and errors
about the .desktop file.  An updated spec that works around those warnings is
at:
http://fedorapeople.org/~tmz/libgpod-0.5.2-update/quodlibet-1.0-2.fc8/quodlibet.spec
Comment 2 Jef Spaleta 2007-08-03 14:27:28 EDT
gpodder 0.9.4 should show up in rawhide real-soon-now. It was updated post freeze.
It has a dep on python-gpod
http://koji.fedoraproject.org/koji/buildinfo?buildID=12238
Comment 3 Todd Zullinger 2007-08-03 14:55:01 EDT
Thanks Jef.  Gpodder should be good to go without any rebuild or changes AFAIK.
 Gpodder author Thomas Perl got some help on the gtkpod-devel list with some
patches for the changes in libgpod 0.5.x.  Hopefully once we build things you'll
be able to confirm that.

If you want to get a head start on that, check out the packages I put up at:
http://fedorapeople.org/~tmz/libgpod-0.5.2-update/
Comment 4 Julian Sikorski 2007-08-08 03:58:54 EDT
Any chances we will see these in f7? gtkpod 0.99.10 is said to support gapless
albums, which is a nice feature and will save the necessity to reboot into
windows for iTunes.
Comment 5 Todd Zullinger 2007-08-08 04:23:30 EDT
It depends on whether(In reply to comment #4)
> Any chances we will see these in f7?

I'd like to see that.  But I'm biased as a gtkpod maintainer. :)  We'll have to
see how the other maintainers feel about pushing the update for F7 once we get
it into devel.

> gtkpod 0.99.10 is said to support gapless
> albums, which is a nice feature and will save the necessity to reboot into
> windows for iTunes.

Yeah, gapless support is indeed in 0.99.10.  It only works for mp3's currently,
and even then only for mp3's which have a LAME tag[1].  (If you've got non-lame
encoded mp3's or another ipod supported format and want to help out, post to the
gtkpod-devel list.  Michael Tiffany, the gentleman that did most of the work on
the gapless support could likely use some help testing and working on supporting
other file types, especially if you can help with iTunes compatibility testing.)

[1] http://gabriel.mp3-tech.org/mp3infotag.html
Comment 6 Jeffrey C. Ollie 2007-08-08 09:23:14 EDT
(In reply to comment #1)
> Created an attachment (id=160625) [edit]
> libgpod-0.5.2 compatibility patch for quodlibet
> 
> I think quodlibet is the only package that needs patched for the libgpod
> update.  I sent a note upstream about this, but since I'm not subscribed the
> the quodlibet list I'm not sure if it got through their moderation system.

The patches for Quod Libet have been applied to devel and should be aviailable
from the mirrors.
Comment 7 Todd Zullinger 2007-08-24 12:47:04 EDT
Okay, so there's some saying about the best laid plans...  I was waiting to hear
back from rel-eng to make sure I did the push properly and handled the merging
of the python-gpod package and then we'd be good to go.  But ajax beat me to it
and rebuilt libgpod this morning. :)

So, amarok, kipi-plugins, gtkpod, quodlibet, and rhythmbox should be rebuilt
before the next rawhide push.  I'm going to do kipi-plugins, gtkpod, and
rhythmbox in the next hour or so.  If there's no objection, I'll do the same for
amarok and quodlibet soon after that (so that no one gets any broken-dep nag mails).

Sorry for the late notice.
Comment 8 Todd Zullinger 2007-08-24 16:09:44 EDT
After waking up a little more, I realized that quodlibet is already good (thanks
Jeff :).  So I built kipi-plugins, gtkpod, and rhythmbox a few hours ago and
just kicked off a rebuild of amarok.

If no problems are found after allowing this to stew in rawhide for a week,
would any of your guys have an objection to pushing this update for F-7?  I'd
like to update gtkpod to pick up some new features.  I don't think it would
cause much trouble for any third-party packages (nothing a rebuild wouldn't fix
that is).  I'd be happy to work out any patches needed by third-party apps that
need libgpod, if there are any that a simple rebuild doesn't work for.

Note You need to log in before you can comment on or make changes to this bug.