Bug 250868 - External usb disk does not work correctly with rawhide 20070801 livecd
Summary: External usb disk does not work correctly with rawhide 20070801 livecd
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 8
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-03 22:26 UTC by Andrea Bruna
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: fedora8test3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-08 20:38:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output of a session with rawhide livecd (78.41 KB, text/plain)
2007-08-03 22:26 UTC, Andrea Bruna
no flags Details

Description Andrea Bruna 2007-08-03 22:26:41 UTC
Description of problem:
The kernel on the rawhide 20070801 livecd does not work reliably with some usb
storage devices. It works fine with my usb flash pen but it does not seem to
works correctly with my external usb hard-disk: after udev mount my ext3
partition the kernel immediately spits out a lot of "Buffer I/O error" and
unmounts the partition, until udev tries again to mount it, the kernel unmount
it due to I/O errors and so on... The problem also happens trying to manually
mount the first partition of the same disk (ntfs). Gparted instead does not even
"see" the disk and if I force a refresh of the devices, it also crashes.

Please, find attached below a copy of dmesg output. 


Version-Release number of selected component (if applicable):
2.6.23-0.61.rc1.git9.fc8

How reproducible:
Connect any external usb 2.0 box using the Cypress AT2 CY7C68300 chipset (mine
is a 300 gb Black Cyclone)

Steps to Reproduce:
1. start the livecd
2. connect an external usb disk to any usb 2.0 connector
3. 
  
Actual results:
The external disk drive is not usable.

Expected results:
The partitions on external devices are mounted and accessible.


Additional info:

Comment 1 Andrea Bruna 2007-08-03 22:26:41 UTC
Created attachment 160676 [details]
dmesg output of a session with rawhide livecd

Comment 2 Andrea Bruna 2007-08-08 10:12:32 UTC
same problem with Fedora8 Test1

Comment 3 Andrea Bruna 2007-10-08 20:38:16 UTC
Problem solved in Fedora 8 Test 3


Note You need to log in before you can comment on or make changes to this bug.