Bug 250874 - Change spec file dependencies to rely on latest versions of components (NSPR, NSS, JSS, MOD_NSS)
Summary: Change spec file dependencies to rely on latest versions of components (NSPR,...
Status: CLOSED ERRATA
Alias: None
Product: Dogtag Certificate System
Classification: Retired
Component: Infrastructure   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
urgent
low
Target Milestone: ---
Assignee: Matthew Harmsen
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 443788 460968
TreeView+ depends on / blocked
 
Reported: 2007-08-03 23:21 UTC by Bob Lord
Modified: 2015-01-04 23:27 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 23:26:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dogtag_diffs (22.04 KB, text/plain)
2009-02-14 20:30 UTC, Matthew Harmsen
no flags Details

Description Thomas Kwan 2007-08-03 23:21:18 UTC
Everything including native-tools, symlink and osutil replies on NSPR 4.6.5, TPS
relies on NSPR 4.6.6. There is nothing specific in TPS that requires 4.6.6.

Comment 1 Red Hat Bugzilla 2007-10-27 15:33:55 UTC
User nkwan@redhat.com's account has been closed

Comment 2 Red Hat Bugzilla 2007-10-27 15:45:47 UTC
User nkwan@redhat.com's account has been closed

Comment 3 Bob Lord 2008-05-04 17:41:09 UTC
Why not use the latest NSPR?


Comment 6 Matthew Harmsen 2009-02-14 20:30:32 UTC
Created attachment 331936 [details]
dogtag_diffs

Comment 8 Matthew Harmsen 2009-02-14 20:32:37 UTC
Per attached diffs, updated the following components:

* NSPR    >= 4.6.99
* NSS     >= 3.12.0
* JSS     >= 4.2.5
* MOD_NSS >= 1.0.7

Comment 9 Matthew Harmsen 2009-02-14 20:34:28 UTC
% svn status | grep -v ^$ | grep -v ^P | grep -v ^X | grep -v ^?
M      java-tools/pki-java-tools.spec
M      symkey/symkey.spec
M      ca/pki-ca.spec
M      common/pki-common.spec
M      silent/pki-silent.spec
M      tks/pki-tks.spec
M      console/pki-console.spec
M      ra/pki-ra.spec
M      ocsp/pki-ocsp.spec
M      tps/pki-tps.spec
M      kra/pki-kra.spec
M      console-ui/dogtag-pki-console-ui.spec
M      util/pki-util.spec

% svn commit
Sending        dogtag/ca/pki-ca.spec
Sending        dogtag/common/pki-common.spec
Sending        dogtag/console/pki-console.spec
Sending        dogtag/console-ui/dogtag-pki-console-ui.spec
Sending        dogtag/java-tools/pki-java-tools.spec
Sending        dogtag/kra/pki-kra.spec
Sending        dogtag/ocsp/pki-ocsp.spec
Sending        dogtag/ra/pki-ra.spec
Sending        dogtag/silent/pki-silent.spec
Sending        dogtag/symkey/symkey.spec
Sending        dogtag/tks/pki-tks.spec
Sending        dogtag/tps/pki-tps.spec
Sending        dogtag/util/pki-util.spec
Transmitting file data .............
Committed revision 229.

Comment 13 Chandrasekar Kannan 2009-06-06 12:30:32 UTC
Steps used to verify:

-[root@sigma ~]# rpm -qa | egrep -i -e nss- -e nspr -e jss -e mod_nss
nss-tools-3.12.2.0-4.el5
mod_nss-1.0.8-1.el5idm
nss-3.12.2.0-4.el5
pkinit-nss-0.7.6-1.el5
jss-4.2.6-1.el5idm
tomcatjss-1.1.0-13.el5idm
nspr-4.7.3-2.el5
nspr-4.7.3-2.el5
nss-3.12.2.0-4.el5
 
- 

Comments:

- This bug is outdated with respect to dependencies as
  further changes are forthcoming wrt nss,jss packages
  for hsm,ipv6 fixes.

__________________________________________________________________
Marking Bug Verified with 06/04/2009 CS8 nightly build
Verified on : RHEL 5.3 x86_64. 
Browser     : Firefox 3.0.10.
HSM used    : nethsm 2000. Firmware: 2.33.60


Note You need to log in before you can comment on or make changes to this bug.