Bug 250877 - NFS panic in shrink_dcache_for_umount_subtree
NFS panic in shrink_dcache_for_umount_subtree
Status: CLOSED DUPLICATE of bug 218718
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
i686 Linux
low Severity urgent
: ---
: ---
Assigned To: Jeff Layton
Martin Jenner
Depends On:
  Show dependency treegraph
Reported: 2007-08-03 19:34 EDT by chakri
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-08-07 10:05:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description chakri 2007-08-03 19:34:18 EDT
Description of problem:

Kernel crashes with the following trace during umount:

BUG: Dentry f7498f70{i=12803e,n=client72} still in use (1) [unmount of nfs 0:18]
------------[ cut here ]------------
kernel BUG at fs/dcache.c:615!
invalid opcode: 0000 [#1]
last sysfs file: /block/ram0/range
Modules linked in: nfs fscache nfsd exportfs lockd nfs_acl ipmi_msghandler
kazprocs(U) sunrpc ipv6 dm_mirror dm_mod video sbs i2c_ec button battery
asus_acpi ac lp floppy snd_intel8x0 snd_ac97_codec snd_ac97
_bus snd_seq_dummy snd_seq_oss snd_seq_midi_event snd_seq snd_seq_device
snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd soundcore snd_page_alloc ide_cd
e100 parport_pc i2c_i801 mii parport pcspkr i2c_core c
drom serio_raw ata_piix libata sd_mod scsi_mod ext3 jbd ehci_hcd ohci_hcd uhci_hcd
CPU:    0
EIP:    0060:[<c047e49f>]    Not tainted VLI
EFLAGS: 00010246   (2.6.18-8.el5 #1)
EIP is at shrink_dcache_for_umount_subtree+0x133/0x1c1
eax: 00000054   ebx: f7498f70   ecx: c0621b24   edx: de121ee8
esi: 00000001   edi: f7835740   ebp: 0012803e   esp: de121ee4
ds: 007b   es: 007b   ss: 0068
Process umount.nfs (pid: 29559, ti=de121000 task=ebbe5000 task.ti=de121000)
Stack: c0621b24 f7498f70 0012803e f7498fd4 00000001 f8d55765 f7835740 f7835600
       f8d67980 00000000 00000000 c047ec5d f7835600 c0470153 00000018 f8d67960
       c0470248 e1b0d380 f8d3a175 f7835600 c04702d7 f74629c0 f7835600 c0483165
Call Trace:
 [<c047ec5d>] shrink_dcache_for_umount+0x2e/0x3a
 [<c0470153>] generic_shutdown_super+0x16/0xd5
 [<c0470248>] kill_anon_super+0x9/0x2f
 [<f8d3a175>] nfs_kill_super+0xc/0x14 [nfs]
 [<c04702d7>] deactivate_super+0x52/0x65
 [<c0483165>] sys_umount+0x1f0/0x218
 [<c059c9eb>] release_sock+0xc/0x91
 [<c05fd48f>] do_page_fault+0x20a/0x4b8
 [<c05fd4f9>] do_page_fault+0x274/0x4b8
 [<c0483198>] sys_oldumount+0xb/0xe
 [<c0403eff>] syscall_call+0x7/0xb
Code: ed 8b 53 0c 8b 33 8b 4b 24 8d b8 40 01 00 00 8b 40 1c 85 d2 8b 00 74 03 8b
6a 20 57 50 56 51 55 53 68 24 1b 62 c0 e8 c5 5c fa ff <0f> 0b 67 02 18 1b 62 c0
83 c4 1c 8b 73 18 39 de 75 04 31 f6 eb
EIP: [<c047e49f>] shrink_dcache_for_umount_subtree+0x133/0x1c1 SS:ESP 0068:de121ee4

It happens prettry regularly after long stress tests with bonnie, doing
intermittent umounts and mounts.

I was able to collect the core, but that did not help much.

Version-Release number of selected component (if applicable):

How reproducible:
Run bonnie & dbench tests with intermittent mounts & umounts.

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Jeff Layton 2007-08-07 10:01:44 EDT
-8.el was the kernel we shipped at RHEL5's release. There have been a few
updates to it since. It would be good to see if you can reproduce it on a more
recent version.

Also, can this be reproduced on a kernel that only contains modules that we
ship? I've never heard of the "kazprocs" module. What exactly does it do?
Comment 3 Jeff Layton 2007-08-07 10:05:28 EDT
Actually, I think this is likely a duplicate of bug #218718.

*** This bug has been marked as a duplicate of 218718 ***

Note You need to log in before you can comment on or make changes to this bug.