Bug 250885 - Error while loading shared libraries: libperl.so: cannot open shared object file: No such file or directory
Error while loading shared libraries: libperl.so: cannot open shared object f...
Status: CLOSED DUPLICATE of bug 240540
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-04 07:35 EDT by Greg Douglas
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-05 22:44:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Douglas 2007-08-04 07:35:12 EDT
Description of problem:

After upgrading from FC6 to Fedora 7, perl no longer works.  Any application
that needs perl displays the following error message:

perl: error while loading shared libraries: libperl.so: cannot open shared
object file: No such file or directory

OR

/usr/bin/perl: error while loading shared libraries: libperl.so: cannot open
shared object file: No such file or directory


I have checked ldd, and there are no dynamic links for perl.

rpm -V perl gives:

prelink: /usr/bin/a2p: at least one of file's dependencies has changed since
prelinking
S.?.....   /usr/bin/a2p




Version-Release number of selected component (if applicable): perl-5.8.8-18.fc7


How reproducible: Every time.


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
worked fin in FC6

Additional info:
Comment 1 Greg Douglas 2007-08-05 12:32:37 EDT
The update from FC6 to Fedora 7 resulted in yum not applying the dependency of
perl-libs.  This package was never installed.  I have manually added this
package, and the other applications appear to work now.  

Is this dependency missing from the rpms file?
Comment 2 Robin Norwood 2007-08-05 22:44:47 EDT
Greg - this is one we're blaming on yum.  See bug #240540

*** This bug has been marked as a duplicate of 240540 ***
Comment 3 Greg Douglas 2007-08-06 08:02:22 EDT
Indeed, thanks Robin.

Note You need to log in before you can comment on or make changes to this bug.