Bug 250894 - gnome-power-manager appears to run but refuses to suspend/hibernate
gnome-power-manager appears to run but refuses to suspend/hibernate
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-power-manager (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-04 13:53 EDT by Michal Jaegermann
Modified: 2013-03-05 22:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-08 18:02:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2007-08-04 13:53:59 EDT
Description of problem:

After 20070803 rawhide changes I do not see anymore "Could
not connect to power manager" complaints and in "Shut Down"
dialog "Hibernate" and "Suspend" buttons were resurected.
In spite of their presence they do not seem to be doing anything
at all.  Once I got an alert informing me that my machine cannot
be suspended and offering to send me to some quirks web page.
Usually there is no visible reaction.

In ~/.xsession-errors for a change I started to collect messages
like:
** (gnome-panel:29635): WARNING **: Could not ask power manager to suspend:
General failure: hal-power-suspend no <-- (action, result)
** (gnome-panel:29635): WARNING **: Could not ask power manager to hibernate:
General failure: hal-power-hibernate no <-- (action, result)

OTOH if I will try to run /usr/sbin/pm-suspend or /usr/sbin/pm-hibernate
then the same machine suspends, hibernates and also restores
entirely as it should and it was doing that all the time when
"Suspend" and "Hibernate" buttons were absent (it sports sometimes
minor hiccups on hibernate but this is not the issue here).

Version-Release number of selected component (if applicable):
gnome-power-manager-2.19.6-1.fc8

How reproducible:
always

Additional info:
I am not really sure if gnome-power-manager is a component
responsible here but it is far from clear to outsiders who
is doing what and to whom.
Comment 1 Michal Jaegermann 2007-08-04 14:20:11 EDT
See also bug 243050.
Comment 2 Michal Jaegermann 2007-08-08 18:02:07 EDT
With the current rawhide (updated to "20070808 changes" level)
"Hibernate" and "Suspend" buttons are operational again. I am not
sure what change really made a difference.  gnome-power-manager
is still the same 2.19.6-1.fc8 while gnome-panel did go to
2.19.5-6.fc8 from 2.19.5-5.fc8.

Hibernate still may, or may not, forget to turn a power off after
it is done, and so far I did not notice any pattern in that, but
this looks like another story.

Note You need to log in before you can comment on or make changes to this bug.