Bug 250902 - cd\dvd burn failures with any buring application
cd\dvd burn failures with any buring application
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-04 17:22 EDT by David Florence
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-18 01:10:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Printout of lsmod (4.06 KB, text/plain)
2007-08-07 13:02 EDT, David Florence
no flags Details
boot message (26.31 KB, text/plain)
2007-08-07 18:34 EDT, David Florence
no flags Details
burn failure (26.40 KB, text/plain)
2007-08-07 18:34 EDT, David Florence
no flags Details
lspci output (37.24 KB, text/plain)
2007-08-07 18:36 EDT, David Florence
no flags Details
Nerolinux log (4.38 KB, text/plain)
2007-08-08 19:37 EDT, David Florence
no flags Details
nerolog (28.31 KB, text/plain)
2007-08-12 15:01 EDT, David Florence
no flags Details

  None (edit)
Description David Florence 2007-08-04 17:22:51 EDT
Description of problem: Burn failures during the burning process, using any
application, i.e. CLI or GUI


Version-Release number of selected component (if applicable):
2.6.22.1-41.fc7

How reproducible: Each attempt


Steps to Reproduce:
1. Load application
2. Choose files to burn
3. Commence the burning process
  
Actual results: Errors from, "input/output error" to "access error".


Expected results: To complete the burning of discs.


Additional info: Will be provided as possible.
Comment 1 Jarod Wilson 2007-08-04 21:08:20 EDT
I presume you have a prior kernel that still burns just fine, so as to eliminate the possibility of hardware 
failure here?
Comment 2 David Florence 2007-08-05 11:53:34 EDT
Had the problem in the previous kernel release.
Have replaced 3 different burners, with the same issue with all. I have
eliminated any possibility of hardware failure.  
Comment 3 Jarod Wilson 2007-08-06 09:18:45 EDT
One more question... We're reasonably confident the drive itself should be fine,
but is it possible we're dealing with a sketchy batch of writable media? In
other words, have you tried with a few different brands of writable media, all
with the same results, or has it been the same batch of media for the life of
the errors?

Just want to be absolutely certain we're not chasing ghosts here.
Comment 4 David Florence 2007-08-06 16:02:44 EDT
I have used several different manufacturers of media, with the same results.

Another issue has been occurring, with sound events hanging after several
minutes of uptime. Do not know if this has any relation, but FYI anyway.
Comment 5 Piergiorgio Sartor 2007-08-07 04:41:38 EDT
(In reply to comment #4)
> I have used several different manufacturers of media, with the same results.

Well, and what about different motherboard, cables, power supply, etc.?

Almost each component in the PC could be a cause of the failure.

Cables are easy to check. BTW, some CD/DVD drives need 80 lines cables, like HDs.

If you have SATA HD and PATA burner, it could be a chipset problem (on the PATA
side), visible only during burning.
Even master and slave PATA differences could lead to similar issues.

The PSU could also be an issue, since during burning, especially DVDs, the drive
peaks current consumption with a noticeable increase compared to normal operation.

In other words, there is lot to check before addressing the kernel.

Do you have any software configuration (FC5, FC6, windows, ...) which was
working in the past or the problem was always there?
Saying differently, did you ever succeed in burning some media?

Comment 6 David Florence 2007-08-07 09:15:56 EDT
Have switched out cables, installed burners in my Windoze box and able to burn
media. I now have 3 workable burners.

The problem started occurring after the first kernel update, from the initial
install of FC7. Each update since then, has caused the increase in errors. Now
with the latest kernel 2.6.22.1-41fc7, I have been unable to burn any media
without a failure.

Since the inception of these issues, I have considered every possibility. The
only piece of hardware not replaced, is the motherboard in the Linux box. That
decision is based on the fact the burners are working in the Windoze box.

Replacing the motherboard will require a new processor, as the Asus A8V-E-SE is
less than 6 months old, it replaced a failed one. It is possible the problem is
with the motherboard. I will make that decision if necessary.
Comment 7 David Florence 2007-08-07 09:18:52 EDT
In addition:

If I do a fresh install of Fedora, to the original kernel, the problem disappears.
Comment 8 Piergiorgio Sartor 2007-08-07 10:44:31 EDT
(In reply to comment #7)
> In addition:
> 
> If I do a fresh install of Fedora, to the original kernel, the problem disappears.

That is a good point.

Which chipset has the MB? Is it VIA based?
Do you know which ATA driver is in use? Possibly "lsmod" (as root) will tell.

Maybe Jarod will be able to identify the component causing the issue.
Comment 9 David Florence 2007-08-07 13:02:01 EDT
Created attachment 160830 [details]
Printout of lsmod
Comment 10 David Florence 2007-08-07 13:05:08 EDT
Comment on attachment 160830 [details]
Printout of lsmod

VIA chipset
K8T890 - VT8237R
Comment 11 Jarod Wilson 2007-08-07 16:38:46 EDT
Nope, I still got nothin'. Please boot the machine replacing the "quiet" option
with "debug" in grub.conf, and then grab dmesg output just after boot and right
after a failed burn attempt. The output of lspci -v might also be insightful,
moreso than lsmod, to show exactly what controller we're dealing with (pata_via
covers quite a few controllers).
Comment 12 David Florence 2007-08-07 18:34:23 EDT
Created attachment 160864 [details]
boot message
Comment 13 David Florence 2007-08-07 18:34:55 EDT
Created attachment 160865 [details]
burn failure
Comment 14 David Florence 2007-08-07 18:36:54 EDT
Created attachment 160866 [details]
lspci output

Here is the information you requested, happy hunting.
Comment 15 Chuck Ebbert 2007-08-08 18:29:29 EDT
Can we get the exact error messages from the burner application? I still don't
see anything other than a kernel message saying the cdrom drive doesn't
recognize the tracks.
Comment 16 David Florence 2007-08-08 19:37:14 EDT
Created attachment 160942 [details]
Nerolinux log

Just happened to obtain one, after several attempts.
Comment 17 Chuck Ebbert 2007-08-09 18:57:19 EDT
The actual error:

05:32:43 PM	#14 SCSI -1182 File SCSIInterface.cpp, Line 366
	SCSI Exec, HA 1, TA 0, LUN 0, buffer 0x0xf00200
	Status:     0x04 (0x01, SCSI_ERR)
	HA-Status   0x00 (0x00, OK)
	TA-Status   0x02 (0x01, SCSI_TASTATUS_CHKCOND)
	Sense Key:  0x07 (Unknown)
	Sense Code: 0x00
	Sense Qual: 0x00
	CDB Data:   0xBF 0x00 0x00 0x00 0x00 0x00 0x00 0x20 0x00 0x0C 0x00 0x00 
	Sense Data: 0x72 0x0B 0x47 0x00 0x00 0x00 0x00 0x0E 
	            0x09 0x0C 0x00 0x00 0x00 0x00 

05:32:43 PM	#15 Text 0 File DVDPlusDualLayer.cpp, Line 653
	L0 Data Zone Capacity not set.
	Max LBA L0 2086911 (1FD7FFh, 4075MB), next writable address 0 (0h, 0MB)
	
05:32:43 PM	#16 CDR -1182 File ThreadedTransferInterface.cpp, Line 1750
	Data protect error
	LITE-ON DVDRW LH-20A1P (H:1 T:0)
Comment 18 Chuck Ebbert 2007-08-09 19:41:03 EDT
BF is "send DVD structure"

Did you try CD media as well as DVD?
Comment 19 David Florence 2007-08-09 19:59:40 EDT
(In reply to comment #18)
> BF is "send DVD structure"
> 
> Did you try CD media as well as DVD?

Yes I did, with the same errors.
Burned 7 CD's before it failed on the eighth disc.
Want a copy of that error, as well?

Comment 20 Chuck Ebbert 2007-08-10 17:00:55 EDT
(In reply to comment #19)
> Burned 7 CD's before it failed on the eighth disc.
> Want a copy of that error, as well?
>

Yes, post that one too.

Comment 21 David Florence 2007-08-12 15:01:59 EDT
Created attachment 161142 [details]
nerolog

Sorry, not familiar with output message, not sure where to locate error.
Comment 22 David Florence 2007-08-18 01:10:23 EDT
Problem has been solved. I was a hardware problem.
Apparently Liteon DVD Rewriters have issues with Linux.
After replacing three Liteon units, with continuous failures and and increase in
coasters, I made the decision to purchase another make of Rewriter, an LG 20X
Super Multi GSA-H55L.
I have been burning CD's and DVD's for 8 hrs a day, for 3 days, without one
failure. At least 25 DVD-DL's,10 Single Sided DVD's and 5 CD's. All discs are
recognized and the drive becomes active when the burn process proceeds.

I apologize for putting you people through the ringer on this one, but I was
having difficulty believing 3 units from one manufacture could be faulty.

I appreciate all you have done to help me, hopefully this will not happen again.

Regards,
David Florence

Note You need to log in before you can comment on or make changes to this bug.