Bug 250908 - yum crash with empty repository
yum crash with empty repository
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-04 20:39 EDT by Ed Swierk
Modified: 2014-01-21 17:59 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 10:44:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for empty repo crash (997 bytes, patch)
2007-08-04 20:39 EDT, Ed Swierk
no flags Details | Diff
Traceback (3.30 KB, text/plain)
2007-08-04 20:41 EDT, Ed Swierk
no flags Details

  None (edit)
Description Ed Swierk 2007-08-04 20:39:59 EDT
yum 3.2.1-1.fc7 crashes due to infinite recursion if run against a repository
containing no rpms.

A patch fixing the bug is attached.

(This problem was reported upstream about a month ago:
https://devel.linux.duke.edu/bugzilla/show_bug.cgi?id=759)
Comment 1 Ed Swierk 2007-08-04 20:39:59 EDT
Created attachment 160705 [details]
Fix for empty repo crash
Comment 2 Ed Swierk 2007-08-04 20:41:08 EDT
Created attachment 160706 [details]
Traceback
Comment 3 Seth Vidal 2007-08-08 02:20:40 EDT
1. I'm sorry, somehow I never got a notice about this bug at linux.duke.edu
bugzilla. That bz instance is not a happy one.

2. I can't figure out a way to replicate this bug. I've tested with 3.2.2 and
current development and I can't make it happen. 

Can you help me with a test case?
thanks
Comment 4 Ed Swierk 2007-08-08 02:37:05 EDT
Woops, I forgot to mention that this only occurs with the priorities plugin
enabled (I noted this in the yum bugzilla report but forgot to copy it over to
this one...).

I'll try to come up with a concise test case tomorrow.
Comment 5 Ed Swierk 2007-08-17 20:01:46 EDT
Here's the easiest way to reproduce the crash on a freshly-installed Fedora 7
system:

- yum install yum-priorities

- edit /etc/yum/plugins.d/priorities.conf:

  [main]
  enabled=1
  check_obsoletes=1

- yum --disablerepo=* update

This is obviously a contrived case, but the crash also occurs if all the enabled
repositories happen to contain no packages.
Comment 6 Ed Swierk 2007-11-14 23:30:04 EST
Ditto on F8.
Comment 7 Seth Vidal 2007-12-06 10:44:15 EST
I can't make this happen on 3.2.8 with priorties installed.

# yum --disablerepo='*' --enablerepo=empty update
Setting up Update Process
No Packages marked for Update


try to replicate this on 3.2.8 in f8 updates-testing or updates and reopen if it
doesn't fix it - but closing this works for me for now.

Note You need to log in before you can comment on or make changes to this bug.