Bug 250914 - installation of x86_64 fails
installation of x86_64 fails
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-05 02:39 EDT by Rudolf Usselmann
Modified: 2008-08-02 19:40 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 22:06:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rudolf Usselmann 2007-08-05 02:39:59 EDT
Description of problem:
After going through all the configuration screens, installation fails.
First I get the window stating "Starting install process. This will take several
minutes". Than I get a window saying "The file xxxx.rpm can not be opened. This
is due to a corruped package or missing file .... bla bla bla [REBOOT] [RETRY]".

Note that "xxxx.rpm" changes every attempt. I verified the media, and also
double checked that the package that is reported as "can not be opened" is
actually there and can be opened on another system.

After starting the installation, and getting the above error, I see the
following after I hit CTRL-ALT-F3:
12:47:35 WARNING Try 1/10 for file:///mnt/source/Fedora/<some_package>.rpm

this is repeated until Try 10/10, and than it says:
12:47:35 WARNING Failed to get file:///mnt/source/Fedora/<some_package>.rpm
from mirror 1/1


Than I go in to sh (CRL-ALT-F2).
I do a "df" and I do not see the DVD mounted

I tried to manually mount the cdrom (scd0) and can see that all the files are
there, but hitting [RETRY] does not appear to help. Doing a 'ps', I see that
anaconda is started with "-m cdrom://scd0:/mnt/source". It seems to me it should
be "/dev/scd0" ?


Version-Release number of selected component (if applicable):
F7 x64_86 DVD ISO image as of 7/31/2007

How reproducible:
Try installing f7 x86_64

Steps to Reproduce:
1. Choose GUI OR text install
2. perform basic configuration
3. start installation 
  
Actual results:
Installation fails reporting that it can not open a package

Expected results:
compleation of installation


Additional info:
Hardware is a Dual Core Athlon CPU, 4G of memory, ASUS MB, Nvidia n70 serries
graphics card
I tried with the built in SATA DVD and also a IDE (PATA) DVD reader. 
Double and tripple checked the media (was burned on the same DVD writer).
Problem occures in both GUI and text mode instalation
I tried maxcpu=1, just because I saw that being mentioned in some other threads ...

Doing a CTRL-ALT-F1, I see several:
(anaconda:760): HtmlUtil-CRITICAL **: html_stream_cancel: assertion
`stream->cancel_func != NULL' failed
These are BEFORE I click "Next" button to start the install process

Id there a way to spcify the cdrom at boot time ?
Comment 1 Jon Stanley 2007-08-05 03:46:45 EDT
FYI I just installed x86_64 F7 release today, although not from DVD (from a
install  tree that I copied from DVD and burned boot.iso instead and did a HTTP
install).  No errors were encountered during this.  I'll attempt a VMWare
install from iso tommorow, but I'm inclined to believe that it will work - the
fact that an HTTP install using a tree created using that media seems to prove it.

Let us know the md5sum of your media (the original iso file), please.
Comment 2 Rudolf Usselmann 2007-08-05 04:46:16 EDT
As requested here is the md5sum:

%md5sum F-7-x86_64-DVD.iso
dd60e7a7f7895cdb2432a4b82f7a5bb1  F-7-x86_64-DVD.iso

I do believe the media is good. The "Media Check" does pass as well. And as I
said the packages that "appear to be missing" are there and can be opened on
another system.
Comment 3 Rudolf Usselmann 2007-08-05 04:53:38 EDT
I also double checked that the sha1sum matches as to what is in the server:

%sha1sum F-7-x86_64-DVD.iso
7cdbd9e1bed9cc9ce2c7970abeaca4da08d2994a  F-7-x86_64-DVD.iso
Comment 4 Rudolf Usselmann 2007-08-07 00:45:09 EDT
I have been comparing how anaconda runs with the 32 bit and
64 bit releases. Apparently the cdrom argument I was questioning
above is ok. It looks like the 32 bit install works the same
way.

I have been monitoring the mounted devices through each step
of the installation. It looks like /tmp/cdrom is properly mounted
on /mnt/source all the way until it starts the actual install.
Basically the last time I have to click a button, when it gives
you the window saying "Starting installation process the the last
time I see /tmp/cdrom being mounted. After that, it magically
disappears, but instead I see /mnt/sysimage being mounted.
Comment 5 Bug Zapper 2008-05-14 09:52:37 EDT
This message is a reminder that Fedora 7 is nearing the end of life. Approximately 30 (thirty) days from now Fedora will stop maintaining and issuing updates for Fedora 7. It is Fedora's policy to close all bug reports from releases that are no longer maintained. At that time this bug will be closed as WONTFIX if it remains open with a Fedora 'version' of '7'.

Package Maintainer: If you wish for this bug to remain open because you plan to fix it in a currently maintained version, simply change the 'version' to a later Fedora version prior to Fedora 7's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that we may not be able to fix it before Fedora 7 is end of life. If you would still like to see this bug fixed and are able to reproduce it against a later version of Fedora please change the 'version' of this bug. If you are unable to change the version, please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's lifetime, sometimes those efforts are overtaken by events. Often a more recent Fedora release includes newer upstream software that fixes bugs or makes them obsolete. If possible, it is recommended that you try the newest available Fedora distribution to see if your bug still exists.

Please read the Release Notes for the newest Fedora distribution to make sure it will meet your needs:
http://docs.fedoraproject.org/release-notes/

The process we are following is described here: http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Andy Lindeberg 2008-06-03 17:01:39 EDT
Have you encountered the same problem in Fedora 9?
Comment 7 Bug Zapper 2008-06-16 22:06:04 EDT
Fedora 7 changed to end-of-life (EOL) status on June 13, 2008. 
Fedora 7 is no longer maintained, which means that it will not 
receive any further security or bug fix updates. As a result we 
are closing this bug. 

If you can reproduce this bug against a currently maintained version 
of Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.