Bug 250930 - Chapter 19.17. Laptop Configurations, mentions nonexistent file /etc/rc3.d/S99XenLaptopNAT
Chapter 19.17. Laptop Configurations, mentions nonexistent file /etc/rc3.d/S9...
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Virtualization_Guide (Show other bugs)
5.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Don Domingo
Content Services Development
http://www.redhat.com/docs/manuals/en...
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-05 10:53 EDT by Marcelo Giles
Modified: 2009-08-20 00:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 20:26:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Original script (532 bytes, text/plain)
2007-08-05 10:55 EDT, Marcelo Giles
no flags Details
Proposed script (643 bytes, text/plain)
2007-08-05 10:57 EDT, Marcelo Giles
no flags Details

  None (edit)
Description Marcelo Giles 2007-08-05 10:53:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.12) Gecko/20070529 Red Hat/1.5.0.12-1.el5 Firefox/1.5.0.12

Description of problem:
Chapter 19.17. Laptop Configurations of the Virtualization Guide reads:

"It is a good idea to enable NAT in domain0 so that domU can access the
public net. This way, even wireless users can work around the Red Hat
Virtualization wireless limitations. To do this, you must modify the
S99XenLaptopNAT  file that resides in the /etc/rc3.d directory to
reflect the example below:"

- Script attached.

I couldn't find the S99XenLaptopNAT file that was supposed to be in
/etc/rc3.d (I'm using RHEL5 Client). But, even if this file existed, it should be a symbolic link pointing to a shell script located in /etc/rc.d/init.d, instead of being the script itself.

This should also take care of the next paragraph, which is innacurate:

"If you want to automatically have the network setup at boot time, you
must create a softlink to /etc/rc3.d/S99XenLaptopNAT."

Because if you already have a script in /etc/rc3.d, it would start the setup anyway (at least in runlevel 3) and because the contents of the /etc/rcX.d directories should be symbolic links only.

- See next attachment for proposed script.

To make the script effective, the steps would be:

1) Create a XenLaptopNAT script file in /etc/rc.d/init.d/ and make it executable, chmod +x XenLaptopNAT.
2) run chkconfig --add XenLaptopNAT. 
3) run chkconfig XenLaptopNAT on.
4) run service XenLaptopNAT start, or reboot the machine to test it.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
Not applicable.

Actual Results:


Expected Results:


Additional info:
Comment 1 Marcelo Giles 2007-08-05 10:55:59 EDT
Created attachment 160710 [details]
Original script
Comment 2 Marcelo Giles 2007-08-05 10:57:03 EDT
Created attachment 160711 [details]
Proposed script
Comment 3 Red Hat Bugzilla 2007-10-02 21:15:30 EDT
User bcleary@redhat.com's account has been closed
Comment 4 David O'Brien 2007-10-02 23:11:16 EDT
Reassigning to Don. Virtualization now part of RHEL.
Comment 5 Don Domingo 2007-10-03 01:26:35 EDT
fixed in source. setting as MODIFIED

Note You need to log in before you can comment on or make changes to this bug.