Bug 250939 - Make dbus stop dumping core for warnings
Make dbus stop dumping core for warnings
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-05 14:58 EDT by Steve Grubb
Modified: 2013-03-05 22:51 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-06 10:54:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch fixing problems described herein (1.66 KB, patch)
2007-08-05 14:58 EDT, Steve Grubb
no flags Details | Diff

  None (edit)
Description Steve Grubb 2007-08-05 14:58:17 EDT
Description of problem:
dbus-libs has a habit of calling abort() for fatal warning which attempts to
generate core files. A core file is not necessary for something like SE Linux
denying access to a file:

open("/var/lib/dbus/machine-id", O_RDONLY) = -1 EACCES (Permission denied)
getpid()                                = 3118
write(2, "process 3118: ", 14)          = 14
write(2, "D-Bus library appears to be inco"..., 198) = 198
write(2, "  D-Bus not built with -rdynamic"..., 64) = 64
tgkill(3118, 3118, SIGABRT)             = 0
--- SIGABRT (Terminated) @ 0 (0) ---
+++ killed by SIGABRT +++

Version-Release number of selected component (if applicable):
1.0.2-6

How reproducible:
everytime

Steps to Reproduce:
1. setenforce 1
2. strace dhcdbd
  
Additional info:
Will attach patch to fix this.
Comment 1 Steve Grubb 2007-08-05 14:58:17 EDT
Created attachment 160717 [details]
patch fixing problems described herein
Comment 2 David Zeuthen 2007-08-06 10:54:11 EDT
This should probably be discussed at the upstream mailing list; either way it
looks like NOTABUG or WONTFIX as this can only happen if D-Bus is incorrectly
installed. Or if SELinux policy or other measures wrongly prevents the process
using libdbus from accessing /var/lib/dbus/machine-id. 

Anyway, closing as UPSTREAM for now.

Note You need to log in before you can comment on or make changes to this bug.